[coreboot-gerrit] New patch to review for coreboot: vboot: Call verification_should_run directly in the if statement

Paul Kocialkowski (contact@paulk.fr) gerrit at coreboot.org
Sat May 14 15:31:38 CEST 2016


Paul Kocialkowski (contact at paulk.fr) just uploaded a new patch set to gerrit, which you can find at https://review.coreboot.org/14817

-gerrit

commit 76a06bf88e59ce7f332d86708972bcc4e37e34dd
Author: Paul Kocialkowski <contact at paulk.fr>
Date:   Sat May 14 15:30:52 2016 +0200

    vboot: Call verification_should_run directly in the if statement
    
    Using a dedicated variable is slightly less readable and makes the code
    less consistent, given that other test functions are called directly in
    the if statements.
    
    Change-Id: If52b2a4268acb1e2187574d15cc73a0c1d5fe9bb
    Signed-off-by: Paul Kocialkowski <contact at paulk.fr>
---
 src/vendorcode/google/chromeos/vboot2/vboot_loader.c | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/src/vendorcode/google/chromeos/vboot2/vboot_loader.c b/src/vendorcode/google/chromeos/vboot2/vboot_loader.c
index 5900613..f6efe0f 100644
--- a/src/vendorcode/google/chromeos/vboot2/vboot_loader.c
+++ b/src/vendorcode/google/chromeos/vboot2/vboot_loader.c
@@ -88,11 +88,7 @@ static int vboot_logic_executed(void)
 
 static void vboot_prepare(void)
 {
-	int run_verification;
-
-	run_verification = verification_should_run();
-
-	if (run_verification) {
+	if (verification_should_run()) {
 		verstage_main();
 		car_set_var(vboot_executed, 1);
 	} else if (verstage_should_load()) {



More information about the coreboot-gerrit mailing list