[coreboot-gerrit] Patch merged into coreboot/master: Clearly define printk log level use cases.

gerrit at coreboot.org gerrit at coreboot.org
Thu Jun 11 20:18:50 CEST 2015

the following patch was just integrated into master:
commit 1f38d7986828fb58ced4a30bb17accb03943e798
Author: Nicky Sielicki <nlsielicki at wisc.edu>
Date:   Sat Jun 6 07:51:54 2015 -0500

    Clearly define printk log level use cases.
    The proper log level for any given printk statement is up to the
    interpretation of the developer. This results in console output with
    somewhat inconsistent levels of verbosity. This patch clearly defines each
    log level and its use case, hopefully resulting in less ambiguity for
    The concern with this patch might be that it leaves a lot of preexisting
    printk statements using a log level that is inconsistent with the
    description. I think that *most* statements map to these extended
    definitions very nicely. The most discrepancies are between debug and
    spew, but I'm willing to say that 95% of statements with a level lower than
    debug are correct by these definitions.
    There was some discussion dating back to 2010 on the mailing list about
    renaming these constants to lose the 'BIOS_' prefix and to consolidate
    some of them into a single constant. I disagree that it is necessary
    to merge any of them, I think they all have unique use cases. But I do
    think that if you all agree with these definitions, it might be useful to
    rename them to reflect their use cases.
    I also will add that I believe removing BIOS_NEVER is a good idea. I do
    not see the use case, and it's used in only 4 files.
    Change-Id: I8aefdd9dee4cb4ad2fc78ee7133a93f8ddf0720b
    Signed-off-by: Nicky Sielicki <nlsielicki at wisc.edu>
    Reviewed-on: http://review.coreboot.org/10444
    Reviewed-by: Patrick Georgi <pgeorgi at google.com>
    Tested-by: build bot (Jenkins)

See http://review.coreboot.org/10444 for details.


More information about the coreboot-gerrit mailing list