[coreboot-gerrit] Patch merged into coreboot/master: 7124788 libpayload: usbmsc: Set correct allocation length for REQUEST SENSE

gerrit at coreboot.org gerrit at coreboot.org
Tue Dec 30 19:00:40 CET 2014


the following patch was just integrated into master:
commit 7124788b335b88c913b04802ddd84db0c438ccc0
Author: Julius Werner <jwerner at chromium.org>
Date:   Fri May 2 14:51:03 2014 -0700

    libpayload: usbmsc: Set correct allocation length for REQUEST SENSE
    
    So I was debugging this faulty USB SD card reader that would just fail
    it's REQUEST SENSE response for some reason (sending the CSW immediately
    without the data), cursing those damn device vendors for building
    non-compliant crap like I always do... when I noticed that we do not
    actually set the Allocation Length field in our REQUEST SENSE command
    block at all! We set a length in the CBW, but the SCSI command still has
    its own length field and the SCSI spec specifically says that the device
    has to return the exact amount of bytes listed there (even if it's 0). I
    don't know what's more suprising: that we had such a blatant bug in this
    stack for so long, or that this card reader is really the first device
    to actually be spec compliant in that regard.
    
    This patch fixes the bug and changes the command block structures to be
    a little easier to read (why that field was called 'lun' before is
    beyond me... LUN is a transport level thing and should never appear in
    the command block at all, for any command). It also fixes a memcpy() in
    wrap_cbw() to avoid a read buffer overflow that might expose stack frame
    data to the device.
    
    BRANCH=rambi?,nyan
    BUG=chrome-os-partner:28437
    TEST=The card reader works now (for it's first LUN at least).
    
    Original-Change-Id: I86fdcae2ea4d2e2939e3676d31d8b6a4e797873b
    Original-Signed-off-by: Julius Werner <jwerner at chromium.org>
    Original-Reviewed-on: https://chromium-review.googlesource.com/198100
    Original-Reviewed-by: Aaron Durbin <adurbin at chromium.org>
    (cherry picked from commit 88943d9715994a14c50e74170f2453cceca0983b)
    Signed-off-by: Marc Jones <marc.jones at se-eng.com>
    
    Change-Id: I3097c223248c07c866a33d4ab8f3db1a7082a815
    Reviewed-on: http://review.coreboot.org/7903
    Reviewed-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>
    Tested-by: build bot (Jenkins)
    Reviewed-by: Edward O'Callaghan <eocallaghan at alterapraxis.com>
    Reviewed-by: Paul Menzel <paulepanter at users.sourceforge.net>


See http://review.coreboot.org/7903 for details.

-gerrit



More information about the coreboot-gerrit mailing list