[coreboot-gerrit] Patch merged into coreboot/master: f898f7b pnp: Provide alternative pnp_enable() implementation

gerrit at coreboot.org gerrit at coreboot.org
Mon Jun 17 21:38:38 CEST 2013


the following patch was just integrated into master:
commit f898f7ba4d10146b45241afe65fd54b3c049cc4f
Author: Nico Huber <nico.h at gmx.de>
Date:   Mon Jun 10 22:57:12 2013 +0200

    pnp: Provide alternative pnp_enable() implementation
    
    The current default implementation of pnp_enable() only disables devices
    - if set so in the devicetree - but does not enable them. Enablement takes
    place in pnp_enable_resources(). Yet, many PnP chips implement their own
    version of pnp_enable() which also enables devices if set in the devicetree.
    
    It's arguable, if enabling those devices makes sense, before they get
    resources assigned. Maybe we can't write the resource registers if not,
    who knows? The least we can do is providing a common implementation for
    this behavior, and get rid of some code duplication.
    
    Used the following cocci:
        @@
        expression e;
        @@
        +pnp_alt_enable(e);
        -pnp_set_logical_device(e);
        (
        -pnp_set_enable(e, !!e->enabled);
        |
        -(e->enabled) ? pnp_set_enable(e, 1) : pnp_set_enable(e, 0);
        |
        -if (e->enabled) { pnp_set_enable(e, 1); }
        -else { pnp_set_enable(e, 0); }
        )
    
    Change-Id: I8d695e8fcd3cf8b847b1aa99326b51a554700bc4
    Signed-off-by: Nico Huber <nico.h at gmx.de>
    Reviewed-on: http://review.coreboot.org/3480
    Tested-by: build bot (Jenkins)
    Reviewed-by: Paul Menzel <paulepanter at users.sourceforge.net>
    Reviewed-by: Ronald G. Minnich <rminnich at gmail.com>
    Reviewed-by: Stefan Reinauer <stefan.reinauer at coreboot.org>


See http://review.coreboot.org/3480 for details.

-gerrit



More information about the coreboot-gerrit mailing list