On my MacBook Air, OSX 10.11, in QEMU while at the OS9 desktop holding left command,  and pressing right command brought up Macsbug.   I do not recall attempting this during boot.

On Feb 25, 2016 2:18 PM, "Programmingkid" <programmingkidx@gmail.com> wrote:

On Feb 25, 2016, at 5:02 PM, BALATON Zoltan wrote:

> On Thu, 25 Feb 2016, Programmingkid wrote:
>> I want to bring up Macsbug while Mac OS 9 is booting. I tried command-powerkey (real left and right command keys) but that didn't work. Command-fn-f12 also didn't work for me. Anybody have any luck with this when using a Mac OS X host?
> I haven't tried but a web search suggests either Command-Eject could work or Ctrl at happy mac display. See:
> http://davespicks.com/writing/programming/mackeys.html

Thanks but I don't think QEMU supports the eject key. I did try the Control key at startup with no luck :(

> Or if these don't work but you can compile programs for MacOS 9 you could make an executable that tries to execute an illegal instruction so starting this executable would bring up the debugger.

I can't run a program while Mac OS 9 is booting up. I'm trying to figure out what is causes problems with Mac OS 9 while booting up in the mac99 target. When I disable all the Open Transport extensions, Mac OS 9.0.4 just stops booting and eventually changes the mouse cursor to a bomb. My current theory is if I return a certain value from escc_mem_read() when Mac OS 9 is looking at the escc, that just might make Mac OS 9 continue to boot. The problem is there are so many possibilities of what can be returned.  Trying to find that right value (if it exists) would probably require looking a PowerPC assembly in Macsbug.
OpenBIOS                 http://openbios.org/
Mailinglist:  http://lists.openbios.org/mailman/listinfo
Free your System - May the Forth be with you