On 22.04.2017 20:16, David Hendricks wrote:
Thanks for getting this discussion going on the list, Nico.
For reference, folks can view the proposed libflashrom.h at https://review.coreboot.org/#/c/17946 to get a better idea for how these prefixes will look in libflashrom functions and data structures.
Also, let's add "fi_" for flashrom interface to the list of proposed prefixes.
My preferences (in order):
IMO not only is "lf_" most intuitive, but the way the keys are spaced apart comfortably on qwerty, dvorak, and colemak layouts and each character (including the underscore) use a different hand to type. Same could be said about fl_ with regards to keyboard layout. fr_ is awkward (keys vertically adjacent) on qwerty and colemak, and fi_ is vertically adjacent on dvorak. flash_ and flashrom_ are not bad but are obviously many more keystrokes.
The problem I have with fl_ is that it is also used for flash layout structs: https://review.coreboot.org/#/c/17944/4/layout.h . The layout structs are used internally and can be changed easily, though.
My bad. Only the `struct fl_layout` is part of the libflashrom inter- face. I removed all other occurrences of the prefix for now from my patches.
flash_ is pretty good - For the most part it flows well with functions such as flash_image_read() and flash_image_write(), but is awkward with some other stuff like "flash_set_log_callback()". If we're already typing >2 letters I think we ought to just use flashrom_ as the prefix to be complete, avoid awkward contexts, and avoid namespace conflicts (users might want to use flash_ in their code).
On Sat, Apr 22, 2017 at 9:42 AM, Nico Huber firstname.lastname@example.org wrote:
Hi flashrom folks,
working again on implementing the libflashrom interface described here . During review  the question arose what `fl_` means and if we don't want to use something else. The following alternatives were pro- posed in the wiki:
- fl_ / FL_ (probably *fl*ashrom)
- lf_ / LF_ (*l*ib *f*lashrom)
- lfr_ / LFR_ (*l*ib *f*lash *r*om)
- rom_ / ROM_
IIRC, on IRC the following was proposed:
- fr_ / FR_ (*f*lash *r*om)
I don't think it has to be an acronym, so I'd add:
- flash_ / FLASH_
- flashrom_ / FLASHROM_
My personal preference would be either `fr_` or `flash_`.
I think this will be open for discussion only for few days. Moving forward is currently more important than finding the perfect name.
Best regards, Nico
flashrom mailing list email@example.com https://mail.coreboot.org/mailman/listinfo/flashrom