On Tue, Dec 15, 2020 at 4:27 PM Jean-Paul Crespy via flashrom <flashrom@flashrom.org> wrote:

As indicated in error message (attached file "flashrom.log"), I transmit
you the requested information.

Best regards

Jean-Paul Crespy

I have a similar AMD motherboard as you, and when I first tried playing with flashrom at the end of August I installed flashrom on FreeBSD. I got the same message as you:
"FCH device found but SMBus revision 0x61 does not match known values."

Well, I am retired and messing with computers is my hobby, so I thought maybe trying a Linux would work better with flashrom, and installed Ubuntu. I still got the same message, and no real answer until Rene' Rebe posted this email on Oct 12:


What I realized was that I needed to download the source, modify a line to include my particular spi chip, compile and install flashrom myself. I looked at the documentation, asked questions, and IT WORKED.
And, besides being able to read my flash chip with flashrom, I have been able to use it to write a stock bios update from MSI on my x570 motherboard, and IT WORKED. The first place to look is here:


So look at  Rene's email & the flashrom download & install info, and ask more questions. Most everyone here is very willing to help.

And, there is a fix in the works on Gerrit by the flashrom developers, but it's not yet released.

You might enjoy the #flashrom & #coreboot channels on Freenode IRC.
Best of luck,