Hi Donald,
Were you able to get it working? With the battery disconnected as you describe flashing with the Bus Pirate should work fine. I suspect there must be a bad connection elsewhere.

You might be able to get further assistance on #flashrom on irc.freenode.net.

On Thu, Jan 14, 2016 at 11:52 PM, Donald Dade <donald.dade@gmail.com> wrote:
Hi again,

Something else which just occurred to me:

I used flashrom on the Chromebook itself to program this very same
chip in the first place, without the -p option, which I assume
defaults to the internal programmer. It worked perfectly. Now that I
bricked it somehow, I tried to restore the BIOS image using flashrom
and the bus pirate as the programmer. This is the failure whose log I
sent you previously.

Any idea why the internal programmer works, but the bus pirate
programmer can't recognize the chip?



On Thu, Jan 14, 2016 at 10:47 PM, Donald Dade <donald.dade@gmail.com> wrote:
> Hi,
> I bricked my Chromebook and am trying to recover it.
> I'm using:
> Ubuntu 15.10
> Bus Pirate v3.6 with firmware v6.2
> flashrom 0.9.8 r1914
> to try to read a:
> Windbond 25Q64FV on a Toshiba Chromebook 2 2015 (battery disconnected)
> by doing:
> sudo ./flashrom-0.9.8-r1914 -p buspirate_spi:dev=/dev/ttyUSB0 -r
> spi.bin -VVV -o log.txt
> but no operations are supported because the chip is not recognized.
> Can you provide any advice on how to move forward?
> Thank you,
> Donald

flashrom mailing list

David Hendricks (dhendrix)
Systems Software Engineer, Google Inc.