Have managed to flash John Lewis's latest rom to my stumpy chromebox, it has revived it and then I installed windows 10 64bit version used it flawlessly for a day, went to shut down and blue power on button just kept flashing so I decided to hold it until it went off, the next day I pressed the power button and now nothing happens, back to were I was before I flashed. (the fan spins for a second and stops for 2 or 3 seconds and repeats this process). Have tested the power supply with a multimeter for voltages and all seems to be good. Do you think my bios chip has failed or could it be more hardware related. 

On Monday, 25 January 2016, 22:58, Stefan Tauner <stefan.tauner@alumni.tuwien.ac.at> wrote:

On Mon, 25 Jan 2016 22:37:18 +0000
Simon Ramage <freeballsdeuce@yahoo.co.uk> wrote:

> Hello, hope you can help me, I have bricked my chromebox, been using a
> pomona clip via a raspberry pi on my spi, running flashrom, which finds my
> winbond chip but when i try to write to it, flashrom comes back with an
> error saying "image size (4096 B) doesn't match the flash chip's size
> (8388608 B)!"

That would mean that you try to write a 4 kB file to an 8 MB flash
chip. flashrom won't allow that for good reasons. It seems like you are
confusing two files IMHO. The 4 kB file is probably just the flash
descriptor but that alone is probably not what you want to write.

> and when i go to the properties of the image it is similar to
> the chip's size.

I certainly doubt that. It is more likely that you are comparing
something else than flashrom does (i.e. you are looking at the wrong

> Have tried using hex editor on windows and flashing that
> format but keep getting same error message, hope you can help me with
> regard to this, thankyou.

You probably want to use a pre-built image by John Lewis. They should
have the correct size...
Kind regards/Mit freundlichen Grüßen, Stefan Tauner