I have the 512KB bios file, and was trying to program it with flashrom and buspirate.
Looks like one version of flashrom says "missing libftdi.dll" while another version says programmer buspirate_spi not supported.
Can you give me link of any latest version. I have tried to copy the libftdi.dll into the flashrom directory, also tried 'regsrv32 libftdi.dll' in a command-box (where regsrv32 looks to be absent in Windows 7)

One more thing, when I hooked up the SPI chip to buspirate, if I use terminal mode of buspirate and set correct mode, then if I try to read some block using CS enables, I get 0x00 and if I keep CS disabled I get 0xFF. I've tried to write anything with both CS enabled and disabled. But values are read as above.
Maybe I've settled up wrong mode while trying to access EEPROM from buspirate terminal mode. . I've worked with mode 5 spi, 125khz, Clock polarity:Idle low , Output clock edge:Active to idle, Input sample phase:middle, Output mode: Normal (H=3.3V, L=GND), W(power supplies on).
I didn't need to do so because for flashing my BIOS chip, I am trying to use flashrom.
This is the fresh chip I bought for recovery. http://in.rsdelivers.com/product/amic-technology/a25l040m-f/spi-flash-4mb-sop8-3v-4mx1/0573498.asp
Note: The BIOS chips is of my tablet, and not PC, so no problem if it takes few days to resolve issues and program it. It isn't much serious case when someone corrupts motherboard's BIOS. I know flashrom's support is free and takes few hours to get reply. It's not an issue in my case.