Edward, thanks a lot! I did a "git clone https://github.com/flashrom/flashrom
Then navigated to flashrom, did a make, make install, (skipped make clean for now)
root@clay-MS-7C37:~/flashrom# flashrom -p internal
flashrom v1.2-163-g855d6b6 on Linux 5.8.0-25-generic (x86_64)
flashrom is free software, get the source code at https://flashrom.org

Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
Found chipset "AMD FP4".
Enabling flash write... Warning: spireadmode not set, leaving spireadmode unchanged.Warning: spispeed not set, leaving spispeed unchanged.OK.
Found Winbond flash chip "W25Q256.W" (32768 kB, SPI) mapped at physical address 0x00000000fe000000.
No operations were specified.

It worked great! I have been looking for this and following it on Gerrit. I see the merge is fresh, 10 hours old. I have a list of at least seven other folks who have 0x59 & 0x61 boards and will notify them too. I do have one who has an 0x51 board with a 0x51 board which is the other email from/to Jean-Paul Crespy. The 0x51 was also listed in Rene Rebe's patch from the flashrom list of Oct 12.

Anyway, thanks for all your work. I did notice you did more than just add 0x59 & 0x61, you made deeper changes that Rene did not think about, and all for the better I must say.


On Wed, Dec 16, 2020 at 4:32 AM Edward O'Callaghan <quasisec@google.com> wrote:
I just noticed this email while searching for 0x61 and thought I would mention that the support for Ryzen style FCH's is actually done and has merged. Feel free to give the tip of the tree a go for your board and let me know if you have any issues with it!

Kind regards,

On Wed, 16 Dec 2020 at 17:20, Clay Daniels <clay.daniels.jr@gmail.com> wrote:
On Tue, Dec 15, 2020 at 4:27 PM Jean-Paul Crespy via flashrom <flashrom@flashrom.org> wrote:

As indicated in error message (attached file "flashrom.log"), I transmit
you the requested information.

Best regards

Jean-Paul Crespy

I have a similar AMD motherboard as you, and when I first tried playing with flashrom at the end of August I installed flashrom on FreeBSD. I got the same message as you:
"FCH device found but SMBus revision 0x61 does not match known values."

Well, I am retired and messing with computers is my hobby, so I thought maybe trying a Linux would work better with flashrom, and installed Ubuntu. I still got the same message, and no real answer until Rene' Rebe posted this email on Oct 12:

What I realized was that I needed to download the source, modify a line to include my particular spi chip, compile and install flashrom myself. I looked at the documentation, asked questions, and IT WORKED.
And, besides being able to read my flash chip with flashrom, I have been able to use it to write a stock bios update from MSI on my x570 motherboard, and IT WORKED. The first place to look is here:

So look at  Rene's email & the flashrom download & install info, and ask more questions. Most everyone here is very willing to help.

And, there is a fix in the works on Gerrit by the flashrom developers, but it's not yet released.

You might enjoy the #flashrom & #coreboot channels on Freenode IRC.
Best of luck,
flashrom mailing list -- flashrom@flashrom.org
To unsubscribe send an email to flashrom-leave@flashrom.org