Hello again,
can not say it in english, but in german:
Ich denke deine "glückwünsche" haben geholfen!!! :-D

Now i'm at home and tested again. And it works! ;-)
Sometimes the reader still "locks up", but the verify is always good!
Maybe my computer at work is bad or it's an ubuntu problem.
Here at home i have LMDE (debian).
The same chip works well here.
I attached logs from read, write, erase and verify.
If you need more tests, just tell me.
The exact name of the chip is "M25P16VG".

About the AT45DB161D:
It's still red and says "no" on the homepage. Because of this i thought its not supported.

And i test it with the AT45DB011B, let's see if it works. ;-)

For the AT-Chips:
The resistor R1 is needed?
And Vcc connect to "hold" and "wp"?

Thanks and greetings


Am 18.10.2013 10:11, schrieb Stefan Tauner:
On Fri, 18 Oct 2013 09:30:11 +0200
Raven <originalraven@hotmail.com> wrote:

I have tried to stabilize the Vcc with an additional Capacitor and cut 
the cables (to minimize the length), but with no luck.

I'm not sure if the Flash is really broken. Maybe the Programmer has a 
Problem (is unstable).
Sometimes the arduino "locks up" and i have to unplug and plug the USB 
again. :-\
I think that is a known issue with the usb to serial
converter of arduino unos. The converter is just another atmel
microcontroller (ATMega<8, 16 or 32>U2), so the issue could potentially
be fixed with a newer firmware... I dont know any details though. "Denis
'GNUtoo' Carikli" <GNUtoo@no-log.org> might know more. I have put him
in CC but he does not have a lot of time lately.

Also tried with the parameter "spispeed=xx" but same (bad) results.

I have an AT45DB011B chip here, but unfortunately this chip is 
unsupported. :-(
Not sure what the difference between the "B" and the "D" is.
The early AT45DB chips (<no suffix>, A, B revisions) do not support any
identification opcodes so flashrom can not detect them at all (and I
skipped adding dedicated support for them). I have never seen a user
reporting one... maybe it works with "-c AT45DB011D -f" but I doubt
it: most chips of the AT45DB family can switch between two major modes
which change the observed address layout. Many of them indicate that in
their status register... the early revisions do not (at least it is not
documented in the datasheet)... the code for AT45DB011D is not designed
to handle that correctly I think... so at least please do not try to
erase/write if the chips contain something useful. :)

But if i have time i try it with a AT45DB161D, this chip should be 
The AT45DB161D is completely tested already, so there is no need to
test it again from our side.

I try to do some tests with other chips, let's see if it works.
Good/better luck! ;)