Cool, glad it worked!

To make things slightly easier, you should also try keeping the CMOS battery and DIM (whatever that is) in.

On Tue, Oct 20, 2015 at 4:51 PM, Arpita Biswas <> wrote:
Hi David, 

That did the trick !!! Thanks a bunch ! For anyone else interested, here is the combination of things I did :

SOIC config as (1) mentioned earlier + held down the power button for 30 sec to reset it + removed CMOS battery + removed jumper on SPI header (that cuts off the processor signal to SPI chip) + plugged in the power cable (that way enough power was there throughout the board for dediprog to detect) + removed the DIM (dunno if that made any difference, but did it since a post mentioned it anyways!).

Dediprog then detected it sweetly :) :)

- Arpita 

On Tue, Oct 20, 2015 at 2:05 PM, David Hendricks <> wrote:

On Tue, Oct 20, 2015 at 12:26 PM, Arpita Biswas <> wrote:
Hi all, 

I am trying to update BIOS with coreboot onto HP Envy H87 haswell chipset (ipm87_mp) . I am using Dediprog + SOIC 8-pin flash clip for flashing the SPI chip (W25Q64). However dediprog doesn't detect the chip when it's soldered on-board. On removing the chip from board, I can detect/read/write onto it without any issues.

I've tried (and failed) with the following configurations :
(1) SPI pin ------> Dediprog : /CS ---> CS, DO (IO1) ---> MISO, /WP (IO2) ---> 3.3V, GND ---> GND, DI (IO0) ---> MOSI, CLK ---> CLK, /HOLD (IO3) ---> 3.3V, VCC ---> 3.3V with motherboard power ON.

(2) Same config as above but I tried to isolate the chip by removing CMOS battery + removing jumper on SPI header + powering OFF the motherboard.

(3) Similar as (1) and (2), but let /HOLD, /Vcc and /WP float.  

(4) I tried using flashrom on the box too as internal programmer, but it did not recognize the SPI chip. Error log says "Found Programmer flash chip "Opaque flash chip" (8192 kB, Programmer-specific)."

I've a feeling that something on the motherboard is interfering with the SPI chip since an off-board chip is working fine. Does anybody have any pointers on what could be going wrong ?

I suspect your motherboard does not isolate the SPI ROM's voltage supply and thus your Dediprog is effectively powering other components on the board.

If you can find a way to hold the PCH and ME in reset while the board is powered on, that might work. Or, with the board off, you can try using an external power supply (the usual warnings about possibly frying your board apply).


Thanks in advance,
- Arpita 

coreboot mailing list:

David Hendricks (dhendrix)
Systems Software Engineer, Google Inc.

David Hendricks (dhendrix)
Systems Software Engineer, Google Inc.