Attention is currently required from: Sam McNally, Anastasia Klimchuk.
9 comments:
File tests/io_mock.h:
Patch Set #7, Line 63: /* Maximum number of open to mock. */
The number is probably arbitrary? If yes, you can add this clarification into a comment, "the number […]
Done
If you are in a good mood, let's make this number power of two :) like 4 for example.
Done
Patch Set #7, Line 118: struct io_mock_open_state *open_state;
This is, as I understand from the code, an alternative to custom open mocking, and mutually exclusiv […]
Done
Patch Set #7, Line 118: open_state
Another thing: could you please add a comment above this line, to explain what that is, something li […]
Done
File tests/io_mock.c:
Patch Set #7, Line 24: assert_true(io == NULL || io->open == NULL || io->open_state == NULL);
I would also add a comment above this line, to make it crystal clear: […]
Done
File tests/tests.c:
Patch Set #7, Line 77: wrap_open_and_friends
Lets just call it "mock_open"
Done
Could you please add new line between two conditionals? It would be easier to read.
Done
Also here, please add new line between declaration of flags and asserts
Done
Also here, please add new line before return statement.
Done
To view, visit change 63227. To unsubscribe, or for help writing mail filters, visit settings.