Attention is currently required from: Miklós Márton, Anastasia Klimchuk.
1 comment:
File jlink_spi.c:
Patch Set #1, Line 55: jaylink_c
The `jaylink_` prefix on these two members is no longer needed imho. […]
I'd move the `jaylink` part to the variable name, maybe shorten it to `jlink`. For example:
static bool assert_cs(struct jlink_spi_data *jlink_data)
{
int ret;
if (jlink_data->reset_cs) {
ret = jaylink_clear_reset(jlink_data->devh);
if (ret != JAYLINK_OK) {
msg_perr("jaylink_clear_reset() failed: %s.\n", jaylink_strerror(ret));
return false;
}
} else {
ret = jaylink_jtag_clear_trst(jlink_data->devh);
if (ret != JAYLINK_OK) {
msg_perr("jaylink_jtag_clear_trst() failed: %s.\n", jaylink_strerror(ret));
return false;
}
}
return true;
}
I would highly prefer to make a separate commit to change this. This kind of change should be reproducible.
To view, visit change 52560. To unsubscribe, or for help writing mail filters, visit settings.