Attention is currently required from: Jack Rosenthal.
6 comments:
File cli_classic.c:
Patch Set #6, Line 152: (argv[optind][0] != '-' || argv[optind][1] == '\0')
!strcmp(argv[optind], "-") would be slightly easier to read, IMO
This is meant to say "and arg[v] does not start with - or if it does it is only '-'" as if it is -something then it is another flag...
File flashrom.c:
Patch Set #6, Line 1351: strncmp(filename, "-", sizeof("-")))
strncmp here is analagous to "starts with" […]
strncmp is considered safer but in this case I think strcmp is fine...
Patch Set #6, Line 1352: fdopen(STDIN_FILENO, "rb")
stdin
fileno(stdin)
Patch Set #6, Line 1367: (strncmp(filename, "-", sizeof("-"))))
same comment as above
Done
Patch Set #6, Line 1444: trncmp(filename, "-", sizeof("-")))
ditto, I don't think we want all files that start with - to act this way
Ack
Patch Set #6, Line 1445: fdopen(STDOUT_FILENO, "wb")
stdout
fileno(stdout)
To view, visit change 52383. To unsubscribe, or for help writing mail filters, visit settings.