Attention is currently required from: Felix Singer, Nico Huber, Angel Pons.
5 comments:
File flashrom.8.tmpl:
Was this removed on purpose?
No. Cleaned up this change.
File tuxedo_ec.c:
Patch Set #1, Line 235: len % BYTES_PER_BLOCK != 0 && len < BYTES_PER_BLOCK
It should be multiple of BYTES_PER_BLOCK
Done
Patch Set #1, Line 433: len % BYTES_PER_BLOCK != 0 && len < BYTES_PER_BLOCK
Are you sure this check is supposed to use an AND? Shouldn't it be checking that the length is a mul […]
Done
if (!ec_wait_for_obuf(ctx_data->control_port,
EC_MAX_STATUS_CHECKS * 3))
return 1;
if (INB(ctx_data->data_port) == 0xf8)
return 0;
Looks like this is open-coding `tuxedo_ec_read_byte` because the `max_checks` parameter isn't expose […]
Added max_checks to all ACPI EC API calls and removed this open-coding
Patch Set #1, Line 504: ++to_chunk
The check below should prevent it. […]
Done
To view, visit change 55715. To unsubscribe, or for help writing mail filters, visit settings.