Nico Huber posted comments on this change.
Patch set 1:
Patch Set #1, Line 326:
Is there anything other than chip erase commands that this applies to? I th
Yes, I've repurposed this later for 4BA-enable functions that need a WREN.
With that said, we could also name the functions after WREN, e.g.
static int spi_simple_wren_cmd(...);
static int spi_wren_cmd(...);
instead of `spi_write_cmd()` (that is added later) as it's also used for
erasures. Or if we want to emphasize the command parts even more:
static int spi_wren_simple_cmd(...);
static int spi_wren_address_cmd(...);
My head is full of ideas, I just don't have a strong preference.
Another thought: Would you prefer both functions to be commented, i.e.
a doxygen style interface documentation? I'm often unsure if it's
necessary as the code is already very specific about what is done ;)
and having it commented means we have to take special care to keep the
comment in sync with the implementation.
To view, visit change 22018. To unsubscribe, visit settings.