Just some comments and nits. We allow up to 112 chars per line
if it increases readability. I think that's the case for all the
prematurely wrapped lines here.
Patch set 1:
Can't we just use `offset`? It seems to be the better name. I was confused
by `addr` in about every other line mentioning it below.
Patch Set #1, Line 255:
Why not continue with the original base?
It seems inconsistent because we continue searching if lb_header_valid() &&
!lb_table_valid() but not if lb_header_valid() && "bad length/mapping"?
Patch Set #1, Line 259:
head = (struct lb_header *)(((char *)base) + addr);
Move this inside the `if` so it becomes clear that it's for the
To view, visit change 37240. To unsubscribe, or for help writing mail filters, visit settings.