Attention is currently required from: Richard Hughes, Edward O'Callaghan, Daniel Campello, Angel Pons, Patrick Rudolph.
17 comments:
Commit Message:
It would be realy good to test it on at least one real programmer, not dummy. For example linux_mtd?
Patchset:
Thank you Daniel, it would be cool to have this work completed!
File cli_output.c:
Space between function name and arguments list not needed.
File flash.h:
Patch Set #11, Line 481: void set_progress(struct flashctx *flash, enum flashrom_progress_stage stage, size_t current, size_t total);
Lets move it into the /* cli_output.c */ section, together with other output stuff.
Here is a bit of an unexpected place to find set_progress.
Patch Set #11, Line 481: set_progress
Looking into the usage of this function, maybe `update_progress` is better name? It is called repeatedly, and it actually updates the same piece of data, progress_userdata again and again.
File libflashrom.h:
Patch Set #11, Line 106: flashrom_set_progress_callback
If set_progress becomes update_progress, this one becomes flashrom_update_progress_callback
File libflashrom.c:
Patch Set #11, Line 102: chaned
chaned -> changed (typo)
Patch Set #11, Line 106: userdata
This is called progress_userdata not userdata?
File spi.c:
size_t progress_start = start;
size_t progress_total = len - start;
I think the variable naming can be improved, I spent a while trying to read this small piece. How about:
progress_start -> start_address
progress_total -> end_address
And I would love to rename start into current_address , but this needs to be a separate patch. So start stays as is for now :\
File spi25.c:
size_t progress_start = start;
size_t progress_total = len - start;
This looks the same as previous, let do
progress_start -> start_address
progress_total -> end_address
size_t progress_start = start;
size_t progress_total = len - start;
And one more here :)
File tests/spi25.c:
assert_true(0);
break;
This probably can be `fail()` , if it's the intention
new line
new line
new line
new line
new line
To view, visit change 49643. To unsubscribe, or for help writing mail filters, visit settings.