This has the potential to obsolete the file arguments to do_read/write/
verify, and save us some code, great! ;)
2 comments:
Patch Set #1, Line 63: entry->name, sizeof(layout.entries[layout.num_entries].name));
Missing '\0' termination in case entry->name is too long.
Anyway, can't you just copy the whole struct?
layout.entries[layout.num_entries] = *entry;
Patch Set #1, Line 271: (l->entries[j].flags & ROMENTRY_FLAG_IGNORE_OVERLAP))
How about a grouping of the entries instead, e.g.
if (l->entries[i].group != l->entries[j].group)
continue;
In any case, I'd move the check above the range checks.
To view, visit change 23353. To unsubscribe, or for help writing mail filters, visit settings.