Attention is currently required from: Richard Hughes, Edward O'Callaghan, Angel Pons, Anastasia Klimchuk, Patrick Rudolph.
16 comments:
Commit Message:
It would be realy good to test it on at least one real programmer, not dummy. […]
I am not completely familiar with the different programmers, but I think the programmer here is spi25 ???
File cli_output.c:
Space between function name and arguments list not needed.
Done
File flash.h:
Patch Set #11, Line 481: set_progress
Looking into the usage of this function, maybe `update_progress` is better name? It is called repeat […]
Done
Patch Set #11, Line 481: void set_progress(struct flashctx *flash, enum flashrom_progress_stage stage, size_t current, size_t total);
Lets move it into the /* cli_output.c */ section, together with other output stuff. […]
This is to support the API exposed via libflashrom and independent from the CLI.
File libflashrom.h:
Patch Set #11, Line 106: flashrom_set_progress_callback
If set_progress becomes update_progress, this one becomes flashrom_update_progress_callback
Done
File libflashrom.c:
Patch Set #11, Line 102: chaned
chaned -> changed (typo)
Done
Patch Set #11, Line 106: userdata
This is called progress_userdata not userdata?
Done
File spi.c:
size_t progress_start = start;
size_t progress_total = len - start;
I think the variable naming can be improved, I spent a while trying to read this small piece. […]
Done
File spi25.c:
size_t progress_start = start;
size_t progress_total = len - start;
This looks the same as previous, let do […]
Done
size_t progress_start = start;
size_t progress_total = len - start;
And one more here :)
Done
File tests/spi25.c:
assert_true(0);
break;
This probably can be `fail()` , if it's the intention
Done
new line
Done
new line
Done
new line
Done
new line
Done
new line
Done
To view, visit change 49643. To unsubscribe, or for help writing mail filters, visit settings.