4 comments:
Patch Set #6, Line 429: ret = 0;
>Without 'reset-mcu' now on the following else statement we specifically set ret to 0. […]
The only thing to change around here is to move the `goto` statement to the other branch of the if-block.
else if
Patch Set #10, Line 452: /* It's fine to not set this parameter. */
Please initialize `*reset` here.
Patch Set #10, Line 476: if (reset) {
I see that the MPU is reset here and during programmer shutdown. This means there should be 4 cases to handle:
The current approach only lets one choose between the first and the last option. Should we account for the two central options, too? This can use flexible syntax, too:
if reset_str contains "pre" then
reset |= RESET_PRE;
end if;
if reset_str contains "post" then
reset |= RESET_POST;
end if;
if reset_str contains "both" then
reset |= RESET_PRE | RESET_POST;
end if;
Something like this would allow one to request a reset before and after flashing using either "pre,post" or "both". It needs more refining, though: "preposterous" would work as well 😄
To view, visit change 45674. To unsubscribe, or for help writing mail filters, visit settings.