Attention is currently required from: Nico Huber, Paul Menzel, Edward O'Callaghan, Angel Pons, Anastasia Klimchuk, Sergii Dmytruk.
3 comments:
File cli_classic.c:
Since permanent and powercycle protection are very rarely supported and not very useful, I think we […]
Resolving
File cli_classic.c:
Patch Set #12, Line 190: wp_cli
I remember there was a conversation about cli vs libflashrom in some other patch in this chain, I ha […]
There is some non-cli logic here (mostly for verifying configuration after writing), but moving it into libflashrom makes it more difficult to implement properly since we often need to write things to stdout/stderr and we shouldn't do that from libflashrom.
The number of libflashrom calls required to do any one operation is already quite small so I don't think we save much by moving more of the code.
ret = wp_cli(
fill_flash,
enable_wp,
disable_wp,
print_wp_status,
print_available_ranges,
set_wp_range,
wp_start,
wp_len,
wp_mode_opt
);
Does this fit into 112 chars? If yes let's have it one line?
It would be around 150 chars, it's probably quite a bit more readable with each parameter on its own line.
To view, visit change 58738. To unsubscribe, or for help writing mail filters, visit settings.