Attention is currently required from: Felix Singer, Thomas Heijligen, Evan Benn.
Patch set 8:Code-Review +1
2 comments:
File tests/selfcheck.c:
assert_table(chip->bustype != BUS_NONE, "chip bustype is BUS_NONE", i,
chip->name);
The full story is here: https://www.flashrom.org/Development_Guidelines#Coding_style
80-columns soft limit for most code and comments. This is to encourage simple design and concise naming.
112-columns hard limit. Use this to reduce line breaks in cases where they harm grep-ability or overall readability, such as print statements and function signatures. Don't abuse this for long variable/function names or deep nesting.
The reason I asked you is because I think this falls under "Use this to reduce line breaks in cases where they harm grep-ability or overall readability".
In general, of course not all the lines should be long! :) If a line is nice and readable within 80 chars, that's perfect.
File tests/selfcheck.c:
#define assert_table(assertion, message, index, name) \
do { \
if (!(assertion)) \
fail_msg(message " for index:%zu name:%s", (index), (name) ? (name) : "unknown"); \
} while (0)
The macro has changed with lot more new lines and \ why?
To view, visit change 69620. To unsubscribe, or for help writing mail filters, visit settings.