Attention is currently required from: Simon Buhrow, Nico Huber, Edward O'Callaghan, Anastasia Klimchuk.
9 comments:
File erasure_layout.c:
`const s`
Done
Patch Set #91, Line 170: old_start_buf
allocation never checked.
Done
add some `\n` to help readability of the function.
Done
trivial: ` (`
Done
trivial: ` (`
Done
Patch Set #91, Line 194: if(erase_layout[i].layout_list[j].selected) {
consider identifying more base-cases to early return/continue/break to avoid deep loops and branches […]
Done
//execute erase
erasefunc_t *erasefn = lookup_erase_func_ptr(erase_layout[i].eraser);
ret = erasefn(flashctx, start_addr, block_len);
if (ret) {
msg_cerr("Failed to execute erase command for offset %#x to %#x.\n", start_addr, start_addr + block_len);
ret = -1;
goto _end;
}
//adjust curcontents
memset(curcontents+start_addr, erased_value, block_len);
//after erase make it unselected again
erase_layout[i].layout_list[j].selected = false;
msg_cdbg("E(%x:%x)", start_addr, start_addr + block_len - 1);
//verify erase
ret = check_erased_range(flashctx, start_addr, block_len);
if (ret) {
msg_cerr("Verifying flash. Erase failed for range %#x : %#x, Abort.\n", start_addr, start_addr + block_len - 1);
goto _end;
}
integrate CB:70517
??
File flashrom.c:
Patch Set #72, Line 1349: static int erase_by_layout
Yeah sorry for the delay. I'm starting to move the implementation to a separate file now.
Done
File flashrom.c:
Patch Set #78, Line 1422: write_by_layout
in a separate commit before this one, rename as `write_by_layout_legacy()` and, […]
Done
To view, visit change 66104. To unsubscribe, or for help writing mail filters, visit settings.