Attention is currently required from: Alan Green, Nico Huber, Edward O'Callaghan, Anastasia Klimchuk, Samir Ibradžić.
7 comments:
Patchset:
PS 29 has not been HW tested yet.
File ft2232_spi.c:
Patch Set #25, Line 189: ft2232_spi_send_command
As mentioned earlier, this is already implemented: default_spi_send_command(). […]
Ack
oh yes... I made a mistake, I didn't notice continue statement. […]
Good idea Nico! It makes the code more readable! Thanks!
Patch Set #25, Line 317: if (!cmds->readcnt && ((cmds + 1)->writecnt || (cmds + 1)->readcnt)){
I think we should check here also if the next command still fits. Might […]
Checking if next command fits is a very good idea! I did as you proposed. However I´m not sure if the '12' is too far from it´s origin if it´s in an extra function.
But this is more a question of taste I think.
More important: I think we need to reset 'i' after send_buf in case the next command does not fit into buffer?
Patch Set #25, Line 343: msg_perr("send_buf failed: %i\n", ret);
If `ret` is non-0, we'd skip the next block, and the loop condition […]
Done.
Very good overview Nico!
* FIXME: This is unreliable. There's no guarantee that
* we read the response directly after sending the read
* command. We may be scheduled out etc.
Looks like you lost a space before each asterisk. […]
Done
Patch Set #25, Line 356: msg_perr("get_buf failed: %i\n", ret);
Sorry, forgot this one, we'd have to `break;` here too on error. Also […]
Done
To view, visit change 40477. To unsubscribe, or for help writing mail filters, visit settings.