6 comments:
Patch Set #4, Line 39: #define SWSPI_WDATA_CLEAR_STATUS
How about adding an extra space between `#define` and the macro name?
#define SWSPI_WDATA 0x90
#define SWSPI_WDATA_CLEAR_STATUS 0x00
Patch Set #4, Line 314: 100000000
`(unsigned)1e8` is more readable.
Or (100 * 1000 * 1000)
Patch Set #4, Line 364: uint8_t write_buffer[len + 1];
I find these VLA usages and clever ptr arithmetic to idx after the few elem a little unsettling. […]
This is quite unsettling, indeed. Is there any reason to not use a fixed-size buffer?
Patch Set #4, Line 365: write_buffer[0] = 0
Why the special treatment for position zero?
SPI
Shouldn't this be guarded like on line 579?
To view, visit change 39687. To unsubscribe, or for help writing mail filters, visit settings.