hi dorileo,
   The card has two UHCI controller and one EHCI controller.And i have already attached a MSC device to the disk. it sill could not run to the function uhci_rh_enable_port

On Tue, Jul 28, 2009 at 9:39 PM, Leandro Dorileo <ldorileo@gmail.com> wrote:
Hi Jason

On Tue, Jul 28, 2009 at 9:17 AM, Jason Wang<wangqingpei@gmail.com> wrote:
> hi Kevin,
>   the attach file is the whole log
>
> On Tue, Jul 28, 2009 at 7:32 AM, Kevin O'Connor <kevin@koconnor.net> wrote:
>>
>> On Mon, Jul 27, 2009 at 11:42:18PM +0800, Jason Wang wrote:
>> > Hi all,
>> >    Since DBM690T does not have UHCI controller, i bought an PCI-USB card
>> > which contained two UHCI controller.



It seems your card(surely) has a single UHCI controller, but (maybe) 2
USB ports(I say based on you log output).



>> > But It always caused rebooting when
>> > the
>> > option rom try to initialize the controller. I attached all of the
>> > messages,
>> > and looking for some help.



I feel it`s stranger to not see any message during the UHCI
initialization, but reboot is normal, if the option ROM don`t do
anything it will fallback to BIOS. I mean by "don`t do anything" if it
doesn`t load the boot sector and/or start executing something when it
finishes the Host Controller initialization.

Your log makes me think you don`t have a MSC device attached to any of
the ports. So I have attached a patch to see if the Root Hub
initialization has successfully finished, could you apply the attached
patch to libpayload and show the output?


>> > Until now my doubt is the real bus/dev/func is 06/05/01, but while
>> > seabios
>> > search it as 00/05/01.
>>
>> Please post a log with the seabios debug level set to 6.
>>
>> -Kevin
>
>
>
> --
> Jason Wang
> Peking University
>

Thanks....

--
(°=   Leandro Dorileo
//\    ldorileo@gmail.com   -   http://www.dorilex.net
V_/  Software is a matter of freedom.



--
Jason Wang
Peking University