Could you put your coreboot .config file somewhere  for us to look at?

The PCI ID of the graphics device (BDF 0:1.0) must match CONFIG_VGA_BIOS_ID
in order for the vga option rom to get loaded. The alternative is to put the vga rom
in the CBFS vgaroms/ directory with any name you want (e.g. vgaroms/matts_vga.rom)
Seabios will then load it.
You can disable CONFIG_VGA_ROM_RUN with this method. Also make sure you
are building your seabios for coreboot.

This would be clearer if your serial console was working. You will want


On Tue, Oct 29, 2013 at 8:29 AM, Haywood-Evans Matthew <> wrote:

I am presently looking at trying to get Coreboot up and running on an
ASUS F2A85-M system. I am however running into some issues.

Using a bus pirate and flashrom I first backed up the original bios,
then erased the chip and restored the bios to ensure I had the basic
read/write capability working and this all worked correctly.

Then I proceeded to build a standard coreboot image using seabios as a
payload (using an external VGA card), leaving all the settings as
default apart from selecting the motherboard, upon writing this to the
flash and rebooting the machine I had no output from the VGA adapter and
nothing from the serial port.

Next I removed the external VGA and followed the instructions at  taking a local copy of the VGA
bios and embedding that into the coreboot image, rebuilt and re-flashed
to get the same result as previous.

After some investigation I created a serial ice image and loaded that,
this worked giving me a serial ice prompt on the COM port.  Using this,
and the QEMU provided, I proceeded to try and run the bios files created
in the last two stages, in the serial ice I see a lot of reads (takes
about 20 mins) before it exits with Bad memory pointer and core dumps.

I have been building the coreboot images on a different machine to the
target (Core i7) but have rebuilt them with the crossgcc in case issues
with the development PC where causing the issue, however I got the same

I am now at a loss of where to go next to get this working and would
appreciate any insight.

The target system I am working on is
4GB Corsair Ram
AMD A10 6800K FM2 CPU


This email and any attachments to it may be confidential and are
intended solely for the use of the individual to whom it is
addressed. If you are not the intended recipient of this email,
you must neither take any action based upon its contents, nor
copy or show it to anyone. Please contact the sender if you
believe you have received this email in error. QinetiQ may
monitor email traffic data and also the content of email for
the purposes of security. QinetiQ Limited (Registered in England
& Wales: Company Number: 3796233) Registered office: Cody Technology
Park, Ively Road, Farnborough, Hampshire, GU14 0LX

coreboot mailing list: