Hi Benjamin,

On Sat, Jan 4, 2020, 01:57 Benjamin Doron <benjamin.doron00@gmail.com> wrote:
Hi again,
I had the display working with Kabylake's VBT but without my laptop's dedicated graphics card. I've since been working on that.

Is this laptop using Nvidia Optimus? If so, the displays are only connected to the integrated GPU.

I added the port for the dGPU ("device pci 01.0") to the devicetree, disabled "SkipExtGfxScan" and set "PrimaryDisplay" to Switchable Graphics, matching, as I see it, the vendor's configuration. This still does not make it work. The display backlight turns on but nothing ever appears on the display. I've even tried it with the added dGPU port as the sole change, with the same result.

I've applied a minimal set of tweaks to the VBT (editing T3 time and PWM frequency to better match the display), but it's otherwise the same as Kabylake's VBT.

What am I missing? Some PCIe configuration? A PCIe root port (vendor UEFI displays one more root port than lspci. I had thought that this could be for M.2/NVMe, whichever this system can support, but I could be wrong, even if "device pci 01.0" is commonly the GPU port)? Should I select ONBOARD_VGA_IS_PRIMARY? Or am I missing some other initialisation that only the OptionROM can do/some GPIO power stuff (I'm using TianoCore, which cannot run them. As Linux appears to ignore them, I thought that this doesn't matter)?

With libgfxinit, you don't need any VBIOS for the Intel GPU. The Nvidia GPU might need a VBIOS, but I don't think you need to run it in coreboot, as the OS should be able to handle it.

I'd appreciate any and all help.
coreboot mailing list -- coreboot@coreboot.org
To unsubscribe send an email to coreboot-leave@coreboot.org

Best regards,