This is mostly the same patch as before, but I separated it into two patches to make the changes easier to follow.

device/device.c:
    Remove references to have_resources.
    Remove read_resources from compute allocate resources.
    Split compute_allocate_resources into two
    1. compute_resource_needs
        A. Traverse the tree depth first
        B. Sum resources
        C. Adjust limits and bases
        D. Update bridge resources sizes
    2. assign_resource_values
        A. Traverse the tree breadth first
        B. Assign resource values

device/device_util.c:
    Remove references to have_resources.

device/pci_device.c:
    Remove saved values stubs (they're not needed now.)
        1. Sizing function restores values
    Fix 64-bit flag masking.
    Add an error message for an invalid value.
    Update pci_record_bridge_resource:
        1. remove compute_allocate_resource call
        2. remove pci_set_resource call
    Update pci_bus_read_resources to read children's too.
    Update pci_set_resource:
        1. change logic for setting zero-size resources
            A. Set range to [limit->limit-2^gran]
                (Could have been any range with base > limit)
        2. remove compute_allocate_resource calls
        3. Change phase4_assign_resources ->phase4_set_resources

device/pci_ops.c:
    Change an error message to be more helpful.

device/root_device.c:
    Remove code for read_resources and set resources.
    Add a .id to the ops.

include/device/device.h:
    Remove have_resources.
    Comment out assign_resources.  I think we could comment out more here.
    Add debugging function prototypes.
    Change phase4_assign_resources to phase4_set_resources.

include/device/resource.h
    Add a IORESOURCE_BRIDGE flag.

device/cardbus_device.c
    Remove compute_allocate_resource call.
    Use probe_resource (doesn't die) instead of find_resource.

Signed-off-by: Myles Watson <mylesgw@gmail.com>

Thanks,
Myles