> have you tried omitting the `deviceĀ lapic` line from the devicetree?
I have tested this, in this case Linux shows only one processor core. Therefore the 'device lapic' line is really needed...

I can submit that Local APIC Fixup patch to gerrit but I'm not sure if this is really the best solution.

Kind regards,

On Wed, Oct 7, 2020 at 6:35 PM Nico Huber <nico.h@gmx.de> wrote:

have you tried omitting the `device lapic` line from the devicetree?
It would only matter if there is configuration associated with it, but
I can't see anything like that for `intel/harcuvar`.

What happens is that this `device lapic` line in the devicetree becomes
an entry in a list at runtime. This list is later filled with the actual
cores present. If any of the actual cores has the same APIC id as given
in the devicetree, no additional entry is added for this core. However
if none of the actual cores has that id, the original entry is left
blindly in the list, causing coreboot to report the spurious, fifth

On 07.10.20 21:27, dponamorev@gmail.com wrote:
> Thank you so much Javier Galindo!
> Sorry for not finding this case myself ...
> I checked it on the motherboard with lapic #4 - everything works as it should.
> Tomorrow I'll check it on the motherboard with lapic #0.
> I wish I could understand how this magic works :)! lapic 0xbeef .....

It's kind of a wildcard that gets replaced with the number found in the
hardware. Nothing too special but probably unnecessary.

coreboot mailing list -- coreboot@coreboot.org
To unsubscribe send an email to coreboot-leave@coreboot.org