Julius Werner uploaded patch set #2 to this change.

View Change

symbols.h: Add macro to define memlayout region symbols

When <symbols.h> was first introduced, it only declared a handful of
regions and we didn't expect that too many architectures and platforms
would need to add their own later. However, our amount of platforms has
greatly expanded since, and with them the need for more special memory
regions. The amount of code duplication is starting to get unsightly,
and platforms keep defining their own <soc/symbols.h> files that need
this as well.

This patch adds another macro to cut down the definition boilerplate.
Unfortunately, macros cannot define other macros when they're called, so
referring to region sizes as _name_size doesn't work anymore. This patch
replaces the scheme with REGION_SIZE(name).

Not touching the regions in the x86-specific <arch/symbols.h> yet since
they don't follow the standard _region/_eregion naming scheme. They can
be converted later if desired.

Change-Id: I44727d77d1de75882c72a94f29bd7e2c27741dd8
Signed-off-by: Julius Werner <jwerner@chromium.org>
---
M src/arch/arm/tables.c
M src/arch/arm64/tables.c
M src/arch/mips/cache.c
M src/arch/x86/acpi_s3.c
M src/cpu/x86/pae/pgtbl.c
M src/drivers/intel/fsp2_0/memory_init.c
M src/drivers/spi/cbfs_spi.c
M src/include/symbols.h
M src/lib/bootblock.c
M src/lib/bootmem.c
M src/lib/cbmem_common.c
M src/lib/cbmem_console.c
M src/lib/stack.c
M src/lib/timestamp.c
M src/mainboard/google/daisy/mainboard.c
M src/mainboard/google/gale/mainboard.c
M src/mainboard/google/gale/mmu.c
M src/mainboard/google/gru/romstage.c
M src/mainboard/google/nyan/mainboard.c
M src/mainboard/google/nyan/romstage.c
M src/mainboard/google/nyan_big/mainboard.c
M src/mainboard/google/nyan_big/romstage.c
M src/mainboard/google/nyan_blaze/mainboard.c
M src/mainboard/google/nyan_blaze/romstage.c
M src/mainboard/google/peach_pit/mainboard.c
M src/mainboard/google/storm/mainboard.c
M src/mainboard/google/storm/mmu.c
M src/mainboard/google/urara/mainboard.c
M src/mainboard/google/veyron/mainboard.c
M src/mainboard/google/veyron/romstage.c
M src/mainboard/google/veyron_mickey/mainboard.c
M src/mainboard/google/veyron_mickey/romstage.c
M src/mainboard/google/veyron_rialto/mainboard.c
M src/mainboard/google/veyron_rialto/romstage.c
M src/security/vboot/common.c
M src/security/vboot/symbols.h
M src/soc/cavium/cn81xx/cpu.c
M src/soc/cavium/cn81xx/include/soc/cpu.h
M src/soc/cavium/cn81xx/mmu.c
M src/soc/cavium/common/bootblock.c
M src/soc/imgtec/pistachio/bootblock.c
M src/soc/mediatek/common/include/soc/mmu_operations.h
M src/soc/mediatek/common/mmu_operations.c
M src/soc/mediatek/mt8173/flash_controller.c
M src/soc/mediatek/mt8173/include/soc/symbols.h
M src/soc/mediatek/mt8173/mmu_operations.c
M src/soc/nvidia/tegra124/verstage.c
M src/soc/nvidia/tegra210/mmu_operations.c
M src/soc/qualcomm/sdm845/include/soc/symbols.h
M src/soc/qualcomm/sdm845/mmu.c
M src/soc/qualcomm/sdm845/soc.c
M src/soc/rockchip/rk3288/bootblock.c
M src/soc/rockchip/rk3288/soc.c
M src/soc/rockchip/rk3399/decompressor.c
M src/soc/rockchip/rk3399/include/soc/symbols.h
M src/soc/rockchip/rk3399/soc.c
M src/soc/samsung/exynos5250/alternate_cbfs.c
M src/soc/samsung/exynos5250/spi.c
M src/soc/samsung/exynos5420/alternate_cbfs.c
M src/soc/samsung/exynos5420/spi.c
M src/vendorcode/google/chromeos/symbols.h
M src/vendorcode/google/chromeos/watchdog.c
62 files changed, 146 insertions(+), 207 deletions(-)

git pull ssh://review.coreboot.org:29418/coreboot refs/changes/39/31539/2

To view, visit change 31539. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I44727d77d1de75882c72a94f29bd7e2c27741dd8
Gerrit-Change-Number: 31539
Gerrit-PatchSet: 2
Gerrit-Owner: Julius Werner <jwerner@chromium.org>
Gerrit-Reviewer: Aaron Durbin <adurbin@chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner@chromium.org>
Gerrit-Reviewer: Patrick Rudolph <siro@das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply@coreboot.org>
Gerrit-MessageType: newpatchset