HAOUAS Elyes has uploaded this change for review.

View Change

src/{device,include}: Use PNP_IDX_EN instead of magic number

Change-Id: I68590605e261ecaace9f3cea28cfa6ec3b913a8a
Signed-off-by: Elyes HAOUAS <ehaouas@noos.fr>
---
M src/device/pnp_device.c
M src/include/device/pnp_ops.h
2 files changed, 7 insertions(+), 5 deletions(-)

git pull ssh://review.coreboot.org:29418/coreboot refs/changes/35/44835/1
diff --git a/src/device/pnp_device.c b/src/device/pnp_device.c
index cd7adf3..9fa032e 100644
--- a/src/device/pnp_device.c
+++ b/src/device/pnp_device.c
@@ -5,6 +5,7 @@
#include <arch/io.h>
#include <device/device.h>
#include <device/pnp.h>
+#include <device/pnp_def.h>

/* PNP config mode wrappers */

@@ -56,7 +57,7 @@
{
u8 tmp, bitpos;

- tmp = pnp_read_config(dev, 0x30);
+ tmp = pnp_read_config(dev, PNP_IDX_EN);

/* Handle virtual devices, which share the same LDN register. */
bitpos = (dev->path.pnp.device >> 8) & 0x7;
@@ -66,14 +67,14 @@
else
tmp &= ~(1 << bitpos);

- pnp_write_config(dev, 0x30, tmp);
+ pnp_write_config(dev, PNP_IDX_EN, tmp);
}

int pnp_read_enable(struct device *dev)
{
u8 tmp, bitpos;

- tmp = pnp_read_config(dev, 0x30);
+ tmp = pnp_read_config(dev, PNP_IDX_EN);

/* Handle virtual devices, which share the same LDN register. */
bitpos = (dev->path.pnp.device >> 8) & 0x7;
diff --git a/src/include/device/pnp_ops.h b/src/include/device/pnp_ops.h
index 0cfdd61..18b35be 100644
--- a/src/include/device/pnp_ops.h
+++ b/src/include/device/pnp_ops.h
@@ -6,6 +6,7 @@
#include <stdint.h>
#include <arch/io.h>
#include <device/pnp.h>
+#include <device/pnp_def.h>
#include <device/pnp_type.h>

#if ENV_PNP_SIMPLE_DEVICE
@@ -32,13 +33,13 @@
static __always_inline
void pnp_set_enable(pnp_devfn_t dev, int enable)
{
- pnp_write_config(dev, 0x30, enable?0x1:0x0);
+ pnp_write_config(dev, PNP_IDX_EN, enable?0x1:0x0);
}

static __always_inline
int pnp_read_enable(pnp_devfn_t dev)
{
- return !!pnp_read_config(dev, 0x30);
+ return !!pnp_read_config(dev, PNP_IDX_EN);
}

static __always_inline

To view, visit change 44835. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I68590605e261ecaace9f3cea28cfa6ec3b913a8a
Gerrit-Change-Number: 44835
Gerrit-PatchSet: 1
Gerrit-Owner: HAOUAS Elyes <ehaouas@noos.fr>
Gerrit-MessageType: newchange