Patch Set 1:

Patch Set 1:

Please see my recent messages at CB:31448 . In short, this patch above, in its' current revision: is not fixing the things but is not breaking them either ( more details at this message - ) so I am not voting on it yet but will be following.

Please provide a coreboot log. Do the ATRM entries show up in ssdt ?
Does Linux attempt to use them ?

Here is a coreboot cbmem log - . Compared to my earlier cbmem log, the only difference observed with the addition of your patch is the insertion of 462 - 466 lines: coreboot tried to access pci1002,6665.rom an extra time while doing ACPI but no ATRM appeared.

Also compared the Linux kernel logs (please let me know if I need to upload because I'd need to clean from serial numbers) - and there are no changes at all, no ATRM either.

Please note that this comparison has been done for "CB:31448 / CB:31449 / CB:31450 applied" to get dGPU working (with VFCT done for dGPU instead of iGPU) vs " ---/the same set/--- + your patch ". I also checked the logs for a build where I tried doing VFCT the way you suggested (for iGPU instead of dGPU, with dGPU failing to initialize later) and there are no ATRM as well.

Are the PCIe slot's ACPI path correct ?

Sorry don't know how to check it, but hopefully it could be visible from cbmem log above. If you'd like you could insert some debug prints to your patch or somehow improve it and I could re-test it.

View Change

To view, visit change 31502. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id2212f29f0de051f6cbd59f8332e86696c1166ab
Gerrit-Change-Number: 31502
Gerrit-PatchSet: 1
Gerrit-Owner: Patrick Rudolph <>
Gerrit-Reviewer: Nico Huber <>
Gerrit-Reviewer: Patrick Rudolph <>
Gerrit-Reviewer: build bot (Jenkins) <>
Gerrit-CC: mikeb mikeb <>
Gerrit-Comment-Date: Thu, 21 Feb 2019 07:50:14 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment