Felix Held has uploaded this change for review.

View Change

mb/google/zork: rename fch_apic_routing struct to fch_irq_routing

fch_apic_routing is used as name of an array that init_tables()
populates with the APIC IRQ routing information. Also the fch_pirq array
where fch_apic_routing was used as struct name contains the IRQ mapping
for both PIC and APIC mode, so rename it to fch_irq_routing.

Change-Id: Iba7a2416c6e07cde1b8618bdabf31b00e3ca4dd1
Signed-off-by: Felix Held <felix-coreboot@felixheld.de>
---
M src/mainboard/google/zork/mainboard.c
1 file changed, 2 insertions(+), 2 deletions(-)

git pull ssh://review.coreboot.org:29418/coreboot refs/changes/69/42569/1
diff --git a/src/mainboard/google/zork/mainboard.c b/src/mainboard/google/zork/mainboard.c
index b17c7f8..f87066a 100644
--- a/src/mainboard/google/zork/mainboard.c
+++ b/src/mainboard/google/zork/mainboard.c
@@ -70,7 +70,7 @@
* This controls the device -> IRQ routing.
* The PIC values are limited to 0,1, 3 - 12, 14, 15.
*/
-static const struct fch_apic_routing {
+static const struct fch_irq_routing {
uint8_t intr_index;
uint8_t pic_irq_num;
uint8_t apic_irq_num;
@@ -96,7 +96,7 @@

static void init_tables(void)
{
- const struct fch_apic_routing *entry;
+ const struct fch_irq_routing *entry;
int i;

memset(fch_pic_routing, PIRQ_NC, sizeof(fch_pic_routing));

To view, visit change 42569. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iba7a2416c6e07cde1b8618bdabf31b00e3ca4dd1
Gerrit-Change-Number: 42569
Gerrit-PatchSet: 1
Gerrit-Owner: Felix Held <felix-coreboot@felixheld.de>
Gerrit-MessageType: newchange