Tim Wawrzynczak uploaded patch set #5 to this change.

View Change

soc/intel/common: Adapt XHCI elog driver for reuse

Currently this XHCI driver assumes the PCH XHCI controller, but the TCSS
or North XHCI block has a similar enough PCI MMIO structure to make this
code mostly reusable.

1) Rename everything to drop the `pch_` prefix
2) xhci_update_wake_event() now takes in a pci_devfn_t for the XHCI
controller
3) soc_get_xhci_usb_info() also now takes a pci_devfn_t for the XHCI
controller

Change-Id: I9f28354e031e3eda587f4faf8ef7595dce8b33ea
Signed-off-by: Tim Wawrzynczak <twawrzynczak@chromium.org>
---
M src/soc/intel/apollolake/elog.c
M src/soc/intel/apollolake/xhci.c
M src/soc/intel/cannonlake/elog.c
M src/soc/intel/cannonlake/xhci.c
M src/soc/intel/common/block/include/intelblocks/xhci.h
M src/soc/intel/common/block/xhci/elog.c
M src/soc/intel/common/block/xhci/xhci.c
M src/soc/intel/jasperlake/elog.c
M src/soc/intel/jasperlake/xhci.c
M src/soc/intel/skylake/elog.c
M src/soc/intel/skylake/xhci.c
M src/soc/intel/tigerlake/elog.c
M src/soc/intel/tigerlake/xhci.c
13 files changed, 138 insertions(+), 162 deletions(-)

git pull ssh://review.coreboot.org:29418/coreboot refs/changes/11/47411/5

To view, visit change 47411. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9f28354e031e3eda587f4faf8ef7595dce8b33ea
Gerrit-Change-Number: 47411
Gerrit-PatchSet: 5
Gerrit-Owner: Tim Wawrzynczak <twawrzynczak@chromium.org>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov@gmail.com>
Gerrit-Reviewer: Caveh Jalali <caveh@chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan@google.com>
Gerrit-Reviewer: Martin Roth <martinroth@google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro@google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi@google.com>
Gerrit-Reviewer: Patrick Rudolph <siro@das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply@coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter@users.sourceforge.net>
Gerrit-MessageType: newpatchset