Felix Held submitted this change.

View Change

Approvals: Marshall Dawson: Looks good to me, approved build bot (Jenkins): Verified Varshit Pandya: Looks good to me, approved
vc/amd/opensil/genoa_poc/mpio: rename mpio_config to configure_mpio

As a preparation for the following patch, rename mpio_config to
configure_mpio to make it both a bit more descriptive and to match the
naming scheme used for the functions that get called by setup_opensil.

Signed-off-by: Felix Held <felix-coreboot@felixheld.de>
Change-Id: Ic4b1aa6e964cbbb4affb89cacd33af8b24871bb6
Reviewed-on: https://review.coreboot.org/c/coreboot/+/80147
Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
Reviewed-by: Marshall Dawson <marshalldawson3rd@gmail.com>
Reviewed-by: Varshit Pandya <pandyavarshit@gmail.com>
---
M src/vendorcode/amd/opensil/genoa_poc/mpio/chip.c
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/vendorcode/amd/opensil/genoa_poc/mpio/chip.c b/src/vendorcode/amd/opensil/genoa_poc/mpio/chip.c
index c268293..49a8934 100644
--- a/src/vendorcode/amd/opensil/genoa_poc/mpio/chip.c
+++ b/src/vendorcode/amd/opensil/genoa_poc/mpio/chip.c
@@ -175,7 +175,7 @@
mpio_port++;
}

-static void mpio_config(void *const config)
+static void configure_mpio(void *const config)
{
MPIOCLASS_INPUT_BLK *mpio_data = SilFindStructure(SilId_MpioClass, 0);
mpio_global_config(mpio_data);
@@ -183,11 +183,11 @@

/* Find all devices with this chip */
for (struct device *dev = &dev_root; dev; dev = dev->next)
- if (dev->chip_ops->init == mpio_config)
+ if (dev->chip_ops->init == configure_mpio)
per_device_config(mpio_data, dev->bus->dev, dev->chip_info);
}

struct chip_operations vendorcode_amd_opensil_genoa_poc_mpio_ops = {
CHIP_NAME("AMD GENOA MPIO")
- .init = mpio_config,
+ .init = configure_mpio,
};

To view, visit change 80147. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ic4b1aa6e964cbbb4affb89cacd33af8b24871bb6
Gerrit-Change-Number: 80147
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot@felixheld.de>
Gerrit-Reviewer: Felix Held <felix-coreboot@felixheld.de>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd@gmail.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit@gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply@coreboot.org>
Gerrit-MessageType: merged