Tim Wawrzynczak has submitted this change. ( https://review.coreboot.org/c/coreboot/+/55097 )
Change subject: drivers/intel/mipi_camera: Add macros to increase code readability ......................................................................
drivers/intel/mipi_camera: Add macros to increase code readability
This will be used to pass information to driver through ACPI in devicetree. Example https://review.coreboot.org/c/coreboot/+/52013
register "clk_panel.clks[0].clknum" = "IMGCLKOUT_3" register "clk_panel.clks[0].freq" = "FREQ_19_2_MHZ"
TEST=Add these macros in devicetree, build and check static.c for consistency
Signed-off-by: Varshit B Pandya varshit.b.pandya@intel.corp-partner.google.com Change-Id: Ia4137e09c934bf06857ceedb933e616bed5070dd Reviewed-on: https://review.coreboot.org/c/coreboot/+/55097 Reviewed-by: Maulik V Vaghela maulik.v.vaghela@intel.com Reviewed-by: Subrata Banik subrata.banik@intel.com Reviewed-by: Paul Menzel paulepanter@mailbox.org Reviewed-by: Rizwan Qureshi rizwan.qureshi@intel.com Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M src/drivers/intel/mipi_camera/chip.h 1 file changed, 8 insertions(+), 0 deletions(-)
Approvals: build bot (Jenkins): Verified Paul Menzel: Looks good to me, but someone else must approve Rizwan Qureshi: Looks good to me, approved Subrata Banik: Looks good to me, approved Maulik V Vaghela: Looks good to me, approved
diff --git a/src/drivers/intel/mipi_camera/chip.h b/src/drivers/intel/mipi_camera/chip.h index 64942b6..35a90bd 100644 --- a/src/drivers/intel/mipi_camera/chip.h +++ b/src/drivers/intel/mipi_camera/chip.h @@ -14,6 +14,14 @@ #define MAX_GPIO_CONFIGS 4 #define MAX_PWR_OPS 5 #define MAX_GUARDED_RESOURCES 10 +#define IMGCLKOUT_0 0 +#define IMGCLKOUT_1 1 +#define IMGCLKOUT_2 2 +#define IMGCLKOUT_3 3 +#define IMGCLKOUT_4 4 +#define IMGCLKOUT_5 5 +#define FREQ_24_MHZ 0 +#define FREQ_19_2_MHZ 1
#define SEQ_OPS_CLK_ENABLE(ind, delay) \ { .type = IMGCLK, .index = (ind), .action = ENABLE, .delay_ms = (delay) }