insomniac has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/41720 )
Change subject: mb/ocp/deltalake: Update SMBIOS type 0 firmware version by VPD variable
......................................................................
Patch Set 11:
(1 comment)
https://review.coreboot.org/c/coreboot/+/41720/11/src/mainboard/ocp/deltala…
File src/mainboard/ocp/deltalake/ramstage.c:
https://review.coreboot.org/c/coreboot/+/41720/11/src/mainboard/ocp/deltala…
PS11, Line 79: const char *smbios_mainboard_bios_version(void)
this feature would be useful beyond just DeltaLake. I am wondering whether we can generalize it in a way that:
* doesn't change coreboot's default behaviour
* allows more granular control (e.g. what is the fallback if the VPD variable is missing?)
Some ideas to do that:
1. make this a global Kconfig tunable (e.g. CONFIG_VERSION_VPD, or any better name), whose value is the name of the VPD variable to read (instead of the hard-coded "version")
2. if this is set, override the default behaviour, otherwise use the normal versioning system
3. add a dependent config value for default value if the VPD var is missing (e.g. CONFIG_VERSION_VPD_DEFAULT_IF_MISSING), whose value would be used if VPD version is missing; and if not set, will return `coreboot_version`
--
To view, visit https://review.coreboot.org/c/coreboot/+/41720
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I98a8fe1135728f31ec154d6340d19be8d8f980ba
Gerrit-Change-Number: 41720
Gerrit-PatchSet: 11
Gerrit-Owner: Jingle Hsu <jingle_hsu(a)wiwynn.com>
Gerrit-Reviewer: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Morgan Jang
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-CC: insomniac <insomniac(a)slackware.it>
Gerrit-Comment-Date: Tue, 02 Jun 2020 17:20:56 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Raul Rangel has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/41584 )
Change subject: DO NOT MERGE: Increase the ACPIGEN stack size
......................................................................
DO NOT MERGE: Increase the ACPIGEN stack size
Picasso currently needs a larger limit. Need to figure out why.
Signed-off-by: Raul E Rangel <rrangel(a)chromium.org>
Change-Id: I2aa1c4dadc4f0405e03d79df4eba8ce685a0e18b
---
M src/acpi/acpigen.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/84/41584/1
diff --git a/src/acpi/acpigen.c b/src/acpi/acpigen.c
index 08f482d..089ce90 100644
--- a/src/acpi/acpigen.c
+++ b/src/acpi/acpigen.c
@@ -1,7 +1,7 @@
/* SPDX-License-Identifier: GPL-2.0-only */
/* How much nesting do we support? */
-#define ACPIGEN_LENSTACK_SIZE 10
+#define ACPIGEN_LENSTACK_SIZE 15
/*
* If you need to change this, change acpigen_write_len_f and
--
To view, visit https://review.coreboot.org/c/coreboot/+/41584
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I2aa1c4dadc4f0405e03d79df4eba8ce685a0e18b
Gerrit-Change-Number: 41584
Gerrit-PatchSet: 1
Gerrit-Owner: Raul Rangel <rrangel(a)chromium.org>
Gerrit-MessageType: newchange
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/41853 )
Change subject: mb/google/dedede: config spk_en gpio to low by default
......................................................................
Patch Set 3:
(1 comment)
https://review.coreboot.org/c/coreboot/+/41853/2/src/mainboard/google/deded…
File src/mainboard/google/dedede/variants/baseboard/gpio.c:
https://review.coreboot.org/c/coreboot/+/41853/2/src/mainboard/google/deded…
PS2, Line 178: GPP_D17
> Hi Furquan, for waddledee audio support is not enabled yet. […]
This is the baseboard GPIO file, so it should apply to all variants.
--
To view, visit https://review.coreboot.org/c/coreboot/+/41853
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I070679457b06cb82633c1197b893a5d89c8b2cf0
Gerrit-Change-Number: 41853
Gerrit-PatchSet: 3
Gerrit-Owner: Usha P <usha.p(a)intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra(a)intel.com>
Gerrit-Reviewer: Divagar Mohandass <divagar.mohandass(a)intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Maulik V Vaghela <maulik.v.vaghela(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 02 Jun 2020 16:53:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Comment-In-Reply-To: Usha P <usha.p(a)intel.com>
Gerrit-MessageType: comment
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/41854 )
Change subject: usb/xhci: Fix timeout logic
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/41854
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I81a888aa0a1544e55e6a680be8f3b7f6e0d87812
Gerrit-Change-Number: 41854
Gerrit-PatchSet: 2
Gerrit-Owner: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Tue, 02 Jun 2020 16:48:16 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment