Elyes HAOUAS has posted comments on this change. ( https://review.coreboot.org/27871 )
Change subject: nb/intel/*: Account for cbmem_top alignment
......................................................................
Patch Set 4:
indeed, it is using an external GPU.
--
To view, visit https://review.coreboot.org/27871
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ifab37b0003f09a680024d5b155ab0bb157920952
Gerrit-Change-Number: 27871
Gerrit-PatchSet: 4
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Elyes HAOUAS <ehaouas(a)noos.fr>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 07 Aug 2018 07:23:44 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: No
Aamir Bohra has uploaded a new patch set (#2). ( https://review.coreboot.org/27889 )
Change subject: src/soc/intel/common: Configure the gspi chip select state correctly
......................................................................
src/soc/intel/common: Configure the gspi chip select state correctly
This implementation updates the chip select control register
programming in gspi controller setup call to program the correct
bit fields for chip select state.
Change-Id: Ifab37b0003f09a680024d5b155ab0bb157920a53
Signed-off-by: Aamir Bohra <aamir.bohra(a)intel.com>
---
M src/soc/intel/common/block/gspi/gspi.c
1 file changed, 1 insertion(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/89/27889/2
--
To view, visit https://review.coreboot.org/27889
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ifab37b0003f09a680024d5b155ab0bb157920a53
Gerrit-Change-Number: 27889
Gerrit-PatchSet: 2
Gerrit-Owner: Aamir Bohra <aamir.bohra(a)intel.com>
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/27871 )
Change subject: nb/intel/*: Account for cbmem_top alignment
......................................................................
Patch Set 4:
> tested on i945g-m4:
> I'm getting Grub2 boot menu faster.
>
> - Linux start, but can see only one CPU. dmsg: " smpboot:
> do_boot_cpu failed(-1) to wakeup CPU#1"
> - S3 not working
> - "# ./flashrom -p internal", gives :
> flashrom v0.9.7-r1711 on Linux 4.17.0-1-amd64 (x86_64)
> flashrom is free software, get the source code at http://www.flashrom.org
>
> Calibrating delay loop... OK.
> Error accessing high tables, 0x100000 bytes at 0x00000000cef38000
> /dev/mem mmap failed: Operation not permitted
> Failed getting access to coreboot high tables.
> Found chipset "Intel ICH7/ICH7R". Enabling flash write... OK.
> Found SST flash chip "SST49LF004A/B" (512 kB, FWH) at physical
> address 0xfff80000.
> No operations were specified.
> to solve this, I need to comment line #949 intel/i945/early_init.c
>
> Console log: https://pastebin.com/6QQKQHa7
Do you happen to run with an external GPU?
--
To view, visit https://review.coreboot.org/27871
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ifab37b0003f09a680024d5b155ab0bb157920952
Gerrit-Change-Number: 27871
Gerrit-PatchSet: 4
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Elyes HAOUAS <ehaouas(a)noos.fr>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 07 Aug 2018 06:59:24 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: No
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/27888
to look at the new patch set (#3).
Change subject: cbmem: rename vdat to chromeos_acpi
......................................................................
cbmem: rename vdat to chromeos_acpi
There is a confusingly named section in cbmem called vdat.
This section holds a data structure called chromeos_acpi_t,
which exposes some system information to the Chrome OS
userland utility crossystem.
Within the chromeos_acpi_t structure, there is a member
called vdat. This (currently) holds a VbSharedDataHeader.
Rename the outer vdat to chromeos_acpi to make its purpose
clear, and prevent the bizarreness of being able to access
vdat->vdat.
Additionally, disallow external references to the
chromeos_acpi data structure in gnvs.c.
BUG=b:112288216
TEST=emerge-eve coreboot, run on eve
CQ-DEPEND=CL:1164722
Signed-off-by: Joel Kitching <kitching(a)google.com>
Change-Id: Ia74e58cde21678f24b0bb6c1ca15048677116b2e
---
M payloads/libpayload/include/coreboot_tables.h
M payloads/libpayload/include/sysinfo.h
M payloads/libpayload/libc/coreboot.c
M src/arch/x86/smbios.c
M src/commonlib/include/commonlib/coreboot_tables.h
M src/lib/coreboot_table.c
M src/vendorcode/google/chromeos/gnvs.c
M src/vendorcode/google/chromeos/gnvs.h
8 files changed, 42 insertions(+), 36 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/88/27888/3
--
To view, visit https://review.coreboot.org/27888
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ia74e58cde21678f24b0bb6c1ca15048677116b2e
Gerrit-Change-Number: 27888
Gerrit-PatchSet: 3
Gerrit-Owner: Joel Kitching <kitching(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Elyes HAOUAS has posted comments on this change. ( https://review.coreboot.org/27871 )
Change subject: nb/intel/*: Account for cbmem_top alignment
......................................................................
Patch Set 4: Code-Review+1
tested on i945g-m4:
I'm getting Grub2 boot menu faster.
- Linux start, but can see only one CPU. dmsg: " smpboot: do_boot_cpu failed(-1) to wakeup CPU#1"
- S3 not working
- "# ./flashrom -p internal", gives :
flashrom v0.9.7-r1711 on Linux 4.17.0-1-amd64 (x86_64)
flashrom is free software, get the source code at http://www.flashrom.org
Calibrating delay loop... OK.
Error accessing high tables, 0x100000 bytes at 0x00000000cef38000
/dev/mem mmap failed: Operation not permitted
Failed getting access to coreboot high tables.
Found chipset "Intel ICH7/ICH7R". Enabling flash write... OK.
Found SST flash chip "SST49LF004A/B" (512 kB, FWH) at physical address 0xfff80000.
No operations were specified.
to solve this, I need to comment line #949 intel/i945/early_init.c
Console log: https://pastebin.com/6QQKQHa7
--
To view, visit https://review.coreboot.org/27871
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ifab37b0003f09a680024d5b155ab0bb157920952
Gerrit-Change-Number: 27871
Gerrit-PatchSet: 4
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Elyes HAOUAS <ehaouas(a)noos.fr>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 07 Aug 2018 06:07:23 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: Yes
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/27888
to look at the new patch set (#2).
Change subject: cbmem: rename vdat to chromeos_acpi
......................................................................
cbmem: rename vdat to chromeos_acpi
There is a confusingly named section in cbmem called vdat.
This section holds a data structure called chromeos_acpi_t,
which exposes some system information to the Chrome OS
userland utility crossystem.
Within the chromeos_acpi_t structure, there is a member
called vdat. This (currently) holds a VbSharedDataHeader.
Rename the outer vdat to chromeos_acpi to make its purpose
clear, and prevent the bizarreness of being able to access
vdat->vdat.
Additionally, disallow external references to the
chromeos_acpi data structure in gnvs.c.
BUG=b:112288216
TEST=emerge-eve coreboot, run on eve
CQ-DEPEND=CL:1164722
Signed-off-by: Joel Kitching <kitching(a)google.com>
Change-Id: Ia74e58cde21678f24b0bb6c1ca15048677116b2e
---
M 3rdparty/blobs
M payloads/libpayload/include/coreboot_tables.h
M payloads/libpayload/include/sysinfo.h
M payloads/libpayload/libc/coreboot.c
M src/arch/x86/smbios.c
M src/commonlib/include/commonlib/coreboot_tables.h
M src/lib/coreboot_table.c
M src/vendorcode/google/chromeos/gnvs.c
M src/vendorcode/google/chromeos/gnvs.h
9 files changed, 43 insertions(+), 37 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/88/27888/2
--
To view, visit https://review.coreboot.org/27888
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ia74e58cde21678f24b0bb6c1ca15048677116b2e
Gerrit-Change-Number: 27888
Gerrit-PatchSet: 2
Gerrit-Owner: Joel Kitching <kitching(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Julius Werner has posted comments on this change. ( https://review.coreboot.org/27884 )
Change subject: security/vboot: Split fwid.region build target
......................................................................
Patch Set 1:
(2 comments)
https://review.coreboot.org/#/c/27884/1//COMMIT_MSG
Commit Message:
https://review.coreboot.org/#/c/27884/1//COMMIT_MSG@11
PS1, Line 11: objects are not invalidated when bumping the fwid.
I don't believe this, actually. I also don't think your patch really makes a practical difference for incremental builts.
Right now, you just have a normal (non-PHONY) rule for the $(obj)/fwid.region target. Once that file exists, it will never be remade (since it doesn't have any prerequisites). So this should never run twice unless you blow away your $(obj) directory (and that makes sense, because the contents of that file only depend on Kconfig, and when you change Kconfig you generally have to blow away everything anyway).
With your change, you have the same sort of situation for the $(obj)/fwid.version target. And then $(obj)/fwid.region gets a dependency to that, so it will only be remade if $(obj)/fwid.version was updated, which will never happen unless it got deleted somehow. So, same situation, practically.
Can you clarify why you believe this target creates a problem in regards to incremental builds?
https://review.coreboot.org/#/c/27884/1/src/security/vboot/Makefile.inc
File src/security/vboot/Makefile.inc:
https://review.coreboot.org/#/c/27884/1/src/security/vboot/Makefile.inc@232
PS1, Line 232: file
Uhhh... either I'm really missing something right now, or this is calling the 'file' utility and connection your firmware version file to it through stdin. So... that makes no sense. I think you meant "$(< $(obj)/fwid.version)"?
--
To view, visit https://review.coreboot.org/27884
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I955106efd648a75a1311f24ede46bd238d1517e0
Gerrit-Change-Number: 27884
Gerrit-PatchSet: 1
Gerrit-Owner: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-Comment-Date: Mon, 06 Aug 2018 22:32:32 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
Richard Spiegel has uploaded this change for review. ( https://review.coreboot.org/27886
Change subject: lib/bootmem.c:Remove unused setting of variable "begin"
......................................................................
lib/bootmem.c:Remove unused setting of variable "begin"
The variable "begin" is extracted from the structure, but 4 lines below
it's overwritten with "end - size". This causes a static build scan error
that should be fixed. Remove the initial assignment of variable "begin".
BUG=b:112253891
TEST=Build and boot grunt.
Change-Id: I0a265747e61289f045c5cac09e40478bd31e16fc
Signed-off-by: Richard Spiegel <richard.spiegel(a)silverbackltd.com>
---
M src/lib/bootmem.c
1 file changed, 0 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/86/27886/1
diff --git a/src/lib/bootmem.c b/src/lib/bootmem.c
index 66d4592..38fdb1b 100644
--- a/src/lib/bootmem.c
+++ b/src/lib/bootmem.c
@@ -278,7 +278,6 @@
return NULL;
/* region now points to the highest usable region for the given size. */
- begin = range_entry_base(region);
end = range_entry_end(region);
if (end > max_addr)
end = max_addr;
--
To view, visit https://review.coreboot.org/27886
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I0a265747e61289f045c5cac09e40478bd31e16fc
Gerrit-Change-Number: 27886
Gerrit-PatchSet: 1
Gerrit-Owner: Richard Spiegel <richard.spiegel(a)silverbackltd.com>