Michał Masłowski (mtjm(a)mtjm.eu) just uploaded a new patch set to gerrit, which you can find at http://review.coreboot.org/10431
-gerrit
commit 3a7e55cd273f3c01fa1f8f44e0f31d18070208af
Author: Michał Masłowski <mtjm(a)mtjm.eu>
Date: Fri Jun 5 15:40:48 2015 +0200
mainboard/lenovo/t400: Use HDA verbs from Lenovo BIOS
The same values are used on my Lenovo R400 as reported by Francis Rowe
from his T400 and T500.
TEST: Read /proc/asound/card0/codec#0, see that the jack locations
correspond to the board layout, e.g. headphone and microphone
connectors are on front of the laptop, not right. Read
/sys/class/sound/hwC0D0/init_pin_configs, see that it has the same
content with coreboot and Lenovo BIOS.
Change-Id: I60e914ca9fab4bb2c99b4ed9e6d81a0580a88b18
Signed-off-by: Michał Masłowski <mtjm(a)mtjm.eu>
---
src/mainboard/lenovo/t400/hda_verb.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/mainboard/lenovo/t400/hda_verb.c b/src/mainboard/lenovo/t400/hda_verb.c
index beb637f..423d10c 100644
--- a/src/mainboard/lenovo/t400/hda_verb.c
+++ b/src/mainboard/lenovo/t400/hda_verb.c
@@ -23,15 +23,15 @@
const u32 cim_verb_data[] = {
/* coreboot specific header */
0x14f15051, // Conexant CX20561 (Hermosa)
- 0x17aa20ff, // Subsystem ID
+ 0x17aa211c, // Subsystem ID
0x00000008, // Number of entries
/* Pin Widget Verb Table */
- AZALIA_PIN_CFG(0, 0x16, 0x042140f0),
+ AZALIA_PIN_CFG(0, 0x16, 0x022140f0),
AZALIA_PIN_CFG(0, 0x17, 0x61a190f0),
- AZALIA_PIN_CFG(0, 0x18, 0x04a190f0),
- AZALIA_PIN_CFG(0, 0x19, 0x612140f0),
+ AZALIA_PIN_CFG(0, 0x18, 0x02a190f0),
+ AZALIA_PIN_CFG(0, 0x19, 0x40f000f0),
AZALIA_PIN_CFG(0, 0x1a, 0x901701f0),
AZALIA_PIN_CFG(0, 0x1b, 0x40f001f0),
AZALIA_PIN_CFG(0, 0x1c, 0x40f001f0),
the following patch was just integrated into master:
commit 7a8a4ab1d88a411ee0dad23318f98b4f29fd2f60
Author: Julius Werner <jwerner(a)chromium.org>
Date: Fri May 22 16:26:40 2015 -0700
lib: Unify log2() and related functions
This patch adds a few bit counting functions that are commonly needed
for certain register calculations. We previously had a log2()
implementation already, but it was awkwardly split between some C code
that's only available in ramstage and an optimized x86-specific
implementation in pre-RAM that prevented other archs from pulling it
into earlier stages.
Using __builtin_clz() as the baseline allows GCC to inline optimized
assembly for most archs (including CLZ on ARM/ARM64 and BSR on x86), and
to perform constant-folding if possible. What was previously named log2f
on pre-RAM x86 is now ffs, since that's the standard name for that
operation and I honestly don't have the slightest idea how it could've
ever ended up being called log2f (which in POSIX is 'binary(2) LOGarithm
with Float result, whereas the Find First Set operation has no direct
correlation to logarithms that I know of). Make ffs result 0-based
instead of the POSIX standard's 1-based since that is consistent with
clz, log2 and the former log2f, and generally closer to what you want
for most applications (a value that can directly be used as a shift to
reach the found bit). Call it __ffs() instead of ffs() to avoid problems
when importing code, since that's what Linux uses for the 0-based
operation.
CQ-DEPEND=CL:273023
BRANCH=None
BUG=None
TEST=Built on Big, Falco, Jerry, Oak and Urara. Compared old and new
log2() and __ffs() results on Falco for a bunch of test values.
Change-Id: I599209b342059e17b3130621edb6b6bbeae26876
Signed-off-by: Patrick Georgi <pgeorgi(a)chromium.org>
Original-Commit-Id: 3701a16ae944ecff9c54fa9a50d28015690fcb2f
Original-Change-Id: I60f7cf893792508188fa04d088401a8bca4b4af6
Original-Signed-off-by: Julius Werner <jwerner(a)chromium.org>
Original-Reviewed-on: https://chromium-review.googlesource.com/273008
Original-Reviewed-by: Patrick Georgi <pgeorgi(a)chromium.org>
Reviewed-on: http://review.coreboot.org/10394
Tested-by: build bot (Jenkins)
Reviewed-by: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
See http://review.coreboot.org/10394 for details.
-gerrit
the following patch was just integrated into master:
commit 3d02b9c79e8dbe661c9e784519c486b8897b6af5
Author: Philipp Deppenwiese <zaolin(a)das-labor.org>
Date: Wed Jun 3 23:09:36 2015 +0200
mainboard/lenovo/{t430s,t420s,t520,t530,x220}: Add TPM 1.2 mainboard support
Every Lenovo Thinkpad includes a Trusted Platform Module, so we can enable
it for the sandy-/ivybridge platforms.
Change-Id: Icda443ba88c2a49a0033014ce7710dd607fa15dc
Signed-off-by: Philipp Deppenwiese <zaolin(a)das-labor.org>
Reviewed-on: http://review.coreboot.org/10411
Tested-by: build bot (Jenkins)
Reviewed-by: Nicolas Reinecke <nr(a)das-labor.org>
Reviewed-by: Patrick Georgi <pgeorgi(a)google.com>
See http://review.coreboot.org/10411 for details.
-gerrit
the following patch was just integrated into master:
commit 09705ab72457423fc88672cda932f474fee0cfbe
Author: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Date: Sat Mar 21 11:11:58 2015 +0200
AMD K8 fam10: Use parent subordinate to track HT enumeration
Change-Id: I930f2beacdc95d0a7edd07db66a1c2e58bb2f3cd
Signed-off-by: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Reviewed-on: http://review.coreboot.org/8566
Tested-by: build bot (Jenkins)
Reviewed-by: Timothy Pearson <tpearson(a)raptorengineeringinc.com>
See http://review.coreboot.org/8566 for details.
-gerrit
the following patch was just integrated into master:
commit ed7bc2c9cfc690cdb23cc9eb317511431c779e89
Author: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Date: Sun Feb 22 08:27:13 2015 +0200
AMD K8 fam10: Drop extra HT scan_chain() parameters
Change-Id: Ice7cb89c19585cf725b6f73c33443050f8d65418
Signed-off-by: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Reviewed-on: http://review.coreboot.org/8565
Tested-by: build bot (Jenkins)
Reviewed-by: Edward O'Callaghan <edward.ocallaghan(a)koparo.com>
Reviewed-by: Timothy Pearson <tpearson(a)raptorengineeringinc.com>
See http://review.coreboot.org/8565 for details.
-gerrit
the following patch was just integrated into master:
commit e8ea71278c6998f03abd690491fad5f884c618f2
Author: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Date: Sun Feb 22 08:54:45 2015 +0200
AMD K8 fam10: Drop local is_sblink in scan_chains
We can define is_sblink = (max == 0) as sblink is always the
very first chain we scan.
Change-Id: Ibd6b3ea23954ca919ae148604bca2495e9f8753b
Signed-off-by: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Reviewed-on: http://review.coreboot.org/8564
Tested-by: build bot (Jenkins)
Reviewed-by: Edward O'Callaghan <edward.ocallaghan(a)koparo.com>
Reviewed-by: Timothy Pearson <tpearson(a)raptorengineeringinc.com>
See http://review.coreboot.org/8564 for details.
-gerrit
the following patch was just integrated into master:
commit 328531ffc70e4f07bbf475a88bc190f47f4b5900
Author: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Date: Sat Feb 28 12:03:20 2015 +0200
AMD K8 fam10: Drop redundant parameters on scan_chain()
Change-Id: I6041b666e6792cf97b8273ed54832d86af8ed23e
Signed-off-by: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Reviewed-on: http://review.coreboot.org/8563
Tested-by: build bot (Jenkins)
Reviewed-by: Edward O'Callaghan <edward.ocallaghan(a)koparo.com>
Reviewed-by: Timothy Pearson <tpearson(a)raptorengineeringinc.com>
See http://review.coreboot.org/8563 for details.
-gerrit