the following patch was just integrated into master:
commit 30eda3edd72f70b3ff7ef46f5cb6e0e346683062
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Sun Nov 16 20:28:57 2014 -0700
fsp_baytrail: remove register option for TSEG size
Set the UPD entry based on the Kconfig value instead of having two
separate places that the value needs to be set.
Change-Id: I3d32111b59152d0a8fc49e15320c7b5a140228a6
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7490
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
Reviewed-by: FEI WANG <wangfei.jimei(a)gmail.com>
See http://review.coreboot.org/7490 for details.
-gerrit
the following patch was just integrated into master:
commit bdfe98f92fc1e9a69aa30ba87bb679dc28e9727c
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Tue Nov 18 19:52:46 2014 -0700
fsp_baytrail: update printk to use FSP_INFO_LEVEL
Update the printk statements to use FSP_INFO_LEVEL instead of
BIOS_DEBUG. These values are currently identical, but by using the
second #define, it lets them all be changed as a unit. This can
be overridden for a particular platform by adding a #define in
chipset_fsp_util.c.
Change-Id: Idbf7e55090230ec940c7c8cd3ec8632461561428
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7520
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
See http://review.coreboot.org/7520 for details.
-gerrit
the following patch was just integrated into master:
commit 12d86e75b067313e3464ebbc9d1ab2cd62fd61fc
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Sun Nov 16 20:53:14 2014 -0700
fsp_baytrail: update for UPD_DEVICE_CHECK macro
- Update chipset_fsp_util.c to use the UPD_DEVICE_CHECK macro. This
makes the code more standardized and easier to read.
- Add some debug printing that was removed in the transition.
Change-Id: Iea24dd9ca53f39791bc6371291a3fa7a6fc5ed0f
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7498
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
See http://review.coreboot.org/7498 for details.
-gerrit
the following patch was just integrated into master:
commit 5c8e7a4075a3f9f86414ea78ee790e04920e332b
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Tue Dec 2 10:49:21 2014 -0700
fsp_baytrail: update to add the UPD_MEMDOWN_CHECK macro
- Update chipset_fsp_util.h to add the UPD_MEMDOWN_CHECK pointing into
the PcdMemoryParameters structure. This is baytrail FSP specific, so
it's put into the chipset code instead of the 'driver' code. Since some
of the values need to be decremented and some do not, a second parameter
was added to control this. This macro also does not print out the
values as they are printed out separately if memory down is enabled.
- Update chipset_fsp_util.c to use the UPD_MEMDOWN_CHECK macro. This
makes the code more standardized and easier to read.
Change-Id: I233e45db43af4726cab41f4880f1706cf8abb0b7
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7632
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
See http://review.coreboot.org/7632 for details.
-gerrit
the following patch was just integrated into master:
commit 8d936ce8538d814c5981d3ac5677b53fc1b90272
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Sun Nov 16 20:07:16 2014 -0700
fsp_baytrail: update for UPD_SPD_CHECK macro
Update chipset_fsp_util.c to use the UPD_SPD_CHECK macro. This
makes the code more standardized and easier to read.
Change-Id: I9944e1a4df82e64a205598e98ed0f3b840af1019
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7489
Reviewed-by: Ronald G. Minnich <rminnich(a)gmail.com>
Tested-by: build bot (Jenkins)
See http://review.coreboot.org/7489 for details.
-gerrit
the following patch was just integrated into master:
commit e8d1901134f01434b09f5edb790ac8465305db1c
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Sun Nov 16 20:06:23 2014 -0700
fsp_baytrail: update to add the UPD_DEFAULT_CHECK macro
- Update chipset_fsp_util.c to use the UPD_DEFAULT_CHECK macro. This
makes the code more standardized and easier to read.
- Update chip.h to use standardized macros
Change-Id: Icbe5ec92b0aa31e21f3dd1593a96b246d83008f7
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7488
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
See http://review.coreboot.org/7488 for details.
-gerrit
the following patch was just integrated into master:
commit 09dd70ebb8f31b36d536f05af289e8edc069c893
Author: Martin Roth <martin.roth(a)se-eng.com>
Date: Sun Nov 16 17:32:56 2014 -0700
drivers/intel/fsp: add upd macros and #defines
Add macros and #defines for working with the UPD data. This makes
the code look much cleaner.
Remove the UPD_ENABLE / UPD_DISABLE from fsp_rangeley/chip.h and include
the fsp_values header instead. This fixes a conflict.
Change-Id: I72c9556065e5c7461432a4593b75da2c8a220a12
Signed-off-by: Martin Roth <martin.roth(a)se-eng.com>
Reviewed-on: http://review.coreboot.org/7487
Tested-by: build bot (Jenkins)
Reviewed-by: Marc Jones <marc.jones(a)se-eng.com>
See http://review.coreboot.org/7487 for details.
-gerrit
Edward O'Callaghan (eocallaghan(a)alterapraxis.com) just uploaded a new patch set to gerrit, which you can find at http://review.coreboot.org/7651
-gerrit
commit b47bcd779d8e0b2824f852c1b9d2a5c336622afc
Author: Edward O'Callaghan <eocallaghan(a)alterapraxis.com>
Date: Fri Dec 5 22:46:02 2014 +1100
mainboard/lenovo/g505s: Build in EC ASL support for KBD/AUX ports
Rather than have Linux report:
i8042: PNP: No PS/2 controller found. Probing directly.
and go off probing PNP config space, build in EC ASL for the
PS/2 keyboard and mouse.
The ASL explicitly passes these resources to the Linux to avoid
said probe.
ASL Details:
PS/2 keyboard (PNP0303 at 0x60,0x64 irq 1 )
PS/2 mouse (PNP0F13 at 0x60,0x64 irq 12)
Change-Id: I0697fab65915907fbe2b3551182b3a1b0d665ddb
Signed-off-by: Edward O'Callaghan <eocallaghan(a)alterapraxis.com>
---
src/mainboard/lenovo/g505s/acpi/superio.asl | 10 ++++++++++
src/mainboard/lenovo/g505s/mainboard.h | 5 +++++
2 files changed, 15 insertions(+)
diff --git a/src/mainboard/lenovo/g505s/acpi/superio.asl b/src/mainboard/lenovo/g505s/acpi/superio.asl
index e69de29..e3bb6fb 100644
--- a/src/mainboard/lenovo/g505s/acpi/superio.asl
+++ b/src/mainboard/lenovo/g505s/acpi/superio.asl
@@ -0,0 +1,10 @@
+/*
+ * Copyright (C) 2014 Edward O'Callaghan <eocallaghan(a)alterapraxis.com>
+ * Subject to the GNU GPL v2, or (at your option) any later version.
+ */
+
+/* Defines EC bits specific to the mainboard, needed by EC ASL */
+#include "mainboard.h"
+
+/* ACPI code for EC SuperIO functions */
+#include <ec/compal/ene932/acpi/superio.asl>
diff --git a/src/mainboard/lenovo/g505s/mainboard.h b/src/mainboard/lenovo/g505s/mainboard.h
index 6131df2..fa8eba8 100644
--- a/src/mainboard/lenovo/g505s/mainboard.h
+++ b/src/mainboard/lenovo/g505s/mainboard.h
@@ -22,4 +22,9 @@
#define PME_GPE 0x0b
#define PCIE_GPE 0x18
+/* Enable PS/2 Keyboard */
+#define SIO_EC_ENABLE_PS2K
+/* Enable PS/2 Mouse */
+#define SIO_EC_ENABLE_PS2M
+
#endif /* _MAINBOARD_LENOVO_G505S_MAINBOARD_H */