<p>Martin Kepplinger has uploaded this change for <strong>review</strong>.</p><p><a href="https://review.coreboot.org/20411">View Change</a></p><pre style="font-family: monospace,monospace; white-space: pre-wrap;">soc/intel/quark/spi.c: Remove unused status assignment<br><br>This removes an unused assignment of the local status variable and thus<br>improves readability. Coverity had found this:<br><br>*** CID 1376473:  Code maintainability issues  (UNUSED_VALUE)<br>/src/soc/intel/quark/spi.c: 169 in xfer()<br>163              }<br>164<br>165                     /* Use chip select 0 */<br>166                    ctrlr->address = (data[0] << 16)<br>167                                 | (data[1] << 8)<br>168                             |  data[2];<br><br>CID 1376473:  Code maintainability issues  (UNUSED_VALUE)<br>Assigning value from "ctrlr->address" to "status" here, but that stored value<br>is overwritten before it can be used.<br><br>169                     status = ctrlr->address;<br>170                data += 3;<br>171                 bytesout -= 3;<br>172             }<br>173<br>174             /* Build the control value */<br><br>Change-Id: I0a364539c37005cfd637b75c8cc23b84e274294d<br>Signed-off-by: Martin Kepplinger <martink@posteo.de><br>---<br>M src/soc/intel/quark/spi.c<br>1 file changed, 0 insertions(+), 1 deletion(-)<br><br></pre><pre style="font-family: monospace,monospace; white-space: pre-wrap;">git pull ssh://review.coreboot.org:29418/coreboot refs/changes/11/20411/1</pre><pre style="font-family: monospace,monospace; white-space: pre-wrap;">diff --git a/src/soc/intel/quark/spi.c b/src/soc/intel/quark/spi.c<br>index 1d257a5..68f445f 100644<br>--- a/src/soc/intel/quark/spi.c<br>+++ b/src/soc/intel/quark/spi.c<br>@@ -166,7 +166,6 @@<br>          ctrlr->address = (data[0] << 16)<br>                            | (data[1] << 8)<br>                                |  data[2];<br>-           status = ctrlr->address;<br>           data += 3;<br>            bytesout -= 3;<br>        }<br></pre><p>To view, visit <a href="https://review.coreboot.org/20411">change 20411</a>. To unsubscribe, visit <a href="https://review.coreboot.org/settings">settings</a>.</p><div itemscope itemtype="http://schema.org/EmailMessage"><div itemscope itemprop="action" itemtype="http://schema.org/ViewAction"><link itemprop="url" href="https://review.coreboot.org/20411"/><meta itemprop="name" content="View Change"/></div></div>

<div style="display:none"> Gerrit-Project: coreboot </div>
<div style="display:none"> Gerrit-Branch: master </div>
<div style="display:none"> Gerrit-MessageType: newchange </div>
<div style="display:none"> Gerrit-Change-Id: I0a364539c37005cfd637b75c8cc23b84e274294d </div>
<div style="display:none"> Gerrit-Change-Number: 20411 </div>
<div style="display:none"> Gerrit-PatchSet: 1 </div>
<div style="display:none"> Gerrit-Owner: Martin Kepplinger <martink@posteo.de> </div>